diff mbox series

[bug#59911,2/7] gnu: Add r-shinycustomloader.

Message ID 20221208211322.28459-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59911,1/7] gnu: Add r-logging. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 9:13 p.m. UTC
* gnu/packages/cran.scm (r-shinycustomloader): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 553c53887c..1a5bef3cdb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17465,6 +17465,29 @@  (define-public r-upsetr
 several common set, element and attribute related tasks.")
     (license license:expat)))
 
+(define-public r-shinycustomloader
+  (package
+    (name "r-shinycustomloader")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "shinycustomloader" version))
+              (sha256
+               (base32
+                "1klx71vr26g0gjf6hbiia1qidqii5d467i1sdjvlrg1hxdcggqff"))))
+    (properties `((upstream-name . "shinycustomloader")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-glue
+           r-shiny))
+    (home-page "https://cran.r-project.org/package=shinycustomloader")
+    (synopsis "Custom loader for Shiny outputs")
+    (description
+     "This package provides a custom @code{CSS/HTML} or @code{GIF/image} file
+for the loading screen in R @code{Shiny}.  It also can use the marquee to have
+a custom text loading screen.")
+    (license license:gpl3)))
+
 ;; This package includes a JavaScript file, which is not minified.  When
 ;; upgrading please check that there are no new minified JavaScript files.
 (define-public r-shinybs