diff mbox series

[bug#59911,1/7] gnu: Add r-logging.

Message ID 20221208211322.28459-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59911,1/7] gnu: Add r-logging. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 9:13 p.m. UTC
* gnu/packages/cran.scm (r-logging): New variable.
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 81191e3410cc00c6438f532599dd0b96d521982f

Comments

Ricardo Wurmus Dec. 12, 2022, 6:03 p.m. UTC | #1
I applied five of these seven patches.  As I wrote earlier
r-shinywidgets contains minified JavaScript that would need to be
compiled from source instead.  Consequently, r-wpm cannot be accepted
because it depends on r-shinywidgets.

Could you please look into compiling the JavaScript from shinywidgets
from source?  We have a couple of other R packages that come with
minified JavaScript, and we modify them to remove the minified
JavaScript in a snippet, add the sources as native inputs, and then use
a build phase to compile them with esbuild.
Vagrant Cascadian Sept. 2, 2023, 4:41 a.m. UTC | #2
retitle 59911 Add r-shinywidgets, r-wpm
thanks

On 2022-12-12, Ricardo Wurmus wrote:
> I applied five of these seven patches.  As I wrote earlier
> r-shinywidgets contains minified JavaScript that would need to be
> compiled from source instead.  Consequently, r-wpm cannot be accepted
> because it depends on r-shinywidgets.

Updating bug title appropriately.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..553c53887c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16814,6 +16814,26 @@  (define-public r-locfdr
 discovery rates.")
     (license license:gpl2)))
 
+(define-public r-logging
+  (package
+    (name "r-logging")
+    (version "0.10-108")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "logging" version))
+              (sha256
+               (base32
+                "13gd40ygx586vs6xcp6clg69a92aj8zxlk1rn3xzkx8klfjimjc5"))))
+    (properties `((upstream-name . "logging")))
+    (build-system r-build-system)
+    (home-page "https://github.com/WLOGSolutions/r-logging")
+    (synopsis "R logging implementation of log4j")
+    (description
+     "This package implements the R version of the @code{log4j} package.  It offers
+hierarchic loggers, multiple handlers per logger, level based filtering, space
+handling in messages and custom formatting.")
+    (license license:gpl3)))
+
 (define-public r-longitudinal
   (package
     (name "r-longitudinal")