diff mbox series

[bug#54335,08/14] gnu: Add go-github-com-songgao-water.

Message ID 20220311031849.12681-8-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-songgao-water): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 20523d9a13..a58b404079 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9931,3 +9931,27 @@  (define-public go-github-com-nbrownus-go-metrics-prometheus
 registry.  It just updates the registry, taking care of exporting the metrics
 is still your responsibility.")
     (license license:asl2.0)))
+
+(define-public go-github-com-songgao-water
+  (package
+    (name "go-github-com-songgao-water")
+    (version "0.0.0-20200317203138-2b4b6d7c09d8")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/songgao/water")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1k5aildfszp6x66jzar4y36lic8ijkb5020hfaivpvq3bnwdiikl"))))
+    (build-system go-build-system)
+    (arguments '(#:tests? #f ; Tests require network access
+                 #:import-path "github.com/songgao/water"))
+    (home-page "https://github.com/songgao/water")
+    (synopsis "Simple network tunnel/tap library")
+    (description
+      "@code{go-github-com-songgao-water} is a simple TUN/TAP interface
+library for Go that efficiently works with standard packages like io, bufio,
+etc..  Use waterutil with it to work with TUN/TAP packets/frames.")
+    (license license:bsd-3)))