diff mbox series

[bug#54335,06/14] gnu: Add go-github-com-miekg-dns.

Message ID 20220311031849.12681-6-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-miekg-dns): New variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b1f23b7eac..d0b5041a8b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9874,3 +9874,32 @@  (define-public go-github-com-google-gopacket
       "@code{go-github-com-google-gopacket} provides packet decoding for the
 Go language.")
     (license license:bsd-3)))
+
+(define-public go-github-com-miekg-dns
+  (package
+    (name "go-github-com-miekg-dns")
+    (version "1.1.46")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/miekg/dns")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "135hnwz3gphgdhs3cs07bvlvbc8k5lh3a75nwkyvl3ylnlf0mpnp"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/miekg/dns"))
+    (native-inputs
+     (list go-golang-org-x-tools
+           go-golang-org-x-sys
+           go-golang-org-x-sync
+           go-golang-org-x-net))
+    (home-page "https://github.com/miekg/dns")
+    (synopsis "Alternative (more granular) approach to a DNS library")
+    (description
+      "@code{go-github-com-miekg-dns} implements a full featured interface to
+the Domain Name System.  Both server and client side programming is supported.
+The package allows complete control over what is sent out to the DNS.  The API
+follows the less-is-more principle, by presenting a small, clean interface.")
+    (license license:bsd-3)))