diff mbox series

[bug#54335,07/14] gnu: Add go-github-com-nbrownus-go-metrics-prometheus.

Message ID 20220311031849.12681-7-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-nbrownus-go-metrics-prometheus): New
variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

M March 11, 2022, 7:46 a.m. UTC | #1
Dominic Martinez schreef op do 10-03-2022 om 22:18 [-0500]:
> +(define-public go-github-com-nbrownus-go-metrics-prometheus
> +  (package
> +    (name "go-github-com-nbrownus-go-metrics-prometheus")
> +    (version "0.0.0-20210712211119-974a6260965f")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/nbrownus/go-metrics-prometheus")

Why use a fork instead of the upstream
<https://github.com/deathowl/go-metrics-prometheus>?  If the fork is
actually necessary (e.g. extra features), could you add a link to the
pull request upstream merging the nbrownus fork back into deathowl?

Greetings,
Maxime.
Dominic Martinez March 11, 2022, 8:24 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> Why use a fork instead of the upstream
> <https://github.com/deathowl/go-metrics-prometheus>?  If the 
> fork is
> actually necessary (e.g. extra features), could you add a link 
> to the
> pull request upstream merging the nbrownus fork back into 
> deathowl?

I couldn't find an instance of the features in the fork being 
used, but Nebula specifically uses that fork. Are you suggesting 
patching the source to import the upstream instead?
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d0b5041a8b..20523d9a13 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9903,3 +9903,31 @@  (define-public go-github-com-miekg-dns
 The package allows complete control over what is sent out to the DNS.  The API
 follows the less-is-more principle, by presenting a small, clean interface.")
     (license license:bsd-3)))
+
+(define-public go-github-com-nbrownus-go-metrics-prometheus
+  (package
+    (name "go-github-com-nbrownus-go-metrics-prometheus")
+    (version "0.0.0-20210712211119-974a6260965f")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/nbrownus/go-metrics-prometheus")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/nbrownus/go-metrics-prometheus"))
+    (native-inputs
+     (list go-github-com-stretchr-testify
+           go-github-com-rcrowley-go-metrics
+           go-github-com-prometheus-client-golang))
+    (home-page "https://github.com/nbrownus/go-metrics-prometheus")
+    (synopsis "Prometheus support for go-metrics")
+    (description
+      "@code{go-github-com-nbrownus-go-metrics-prometheus} is a reporter for
+the go-metrics library which will post the metrics to the prometheus client
+registry.  It just updates the registry, taking care of exporting the metrics
+is still your responsibility.")
+    (license license:asl2.0)))