diff mbox series

[bug#54335,04/14] gnu: Add go-github-com-cyberdelia-go-metrics-graphite.

Message ID 20220311031849.12681-4-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-cyberdelia-go-metrics-graphite): New variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index afa99d718e..6eecdbe48e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9820,3 +9820,33 @@  (define-public go-github-com-cespare-xxhash-v2
 xxHash (XXH64) as described at
 @url{http://cyan4973.github.io/xxHash/,http://cyan4973.github.io/xxHash/}.")
     (license license:expat)))
+
+(define-public go-github-com-cyberdelia-go-metrics-graphite
+  (package
+    (name "go-github-com-cyberdelia-go-metrics-graphite")
+    (version "0.0.0-20161219230853-39f87cc3b432")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/cyberdelia/go-metrics-graphite")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1nnpwryw8i110laffyavvhx38gcd1jnpdir69y6fxxzpx06d094w"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     (list go-github-com-rcrowley-go-metrics))
+    (arguments
+     '(#:import-path "github.com/cyberdelia/go-metrics-graphite"
+       ;; Tests use network
+       #:tests? #f))
+    (home-page "https://github.com/cyberdelia/go-metrics-graphite")
+    (synopsis "Graphite client for go-metrics")
+    (description
+      "This is a reporter for the
+@url{https://github.com/rcrowley/go-metrics,go-metrics} library which will post
+the metrics to Graphite.  It was originally part of the @code{go-metrics}
+library itself, but has been split off to make maintenance of both the core
+library and the client easier.")
+    (license license:bsd-2)))