mbox series

[bug#54335,00/14] gnu: Add nebula.

Message ID 20220311031356.12474-1-dom@dominicm.dev
Headers show
Series gnu: Add nebula. | expand

Message

Dominic Martinez March 11, 2022, 3:13 a.m. UTC
This patch series adds Nebula, which is a scalable overlay networking tool
that uses certificates to securely create a peer-to-peer network. This is my
first big patch series, so let me know if something needs to change!

Dominic Martinez (14):
  gnu: Add go-github-com-anmitsu-go-shlex.
  gnu: Add go-github-com-armon-go-radix.
  gnu: Add go-github-com-cespare-xxhash-v2.
  gnu: Add go-github-com-cyberdelia-go-metrics-graphite.
  gnu: Add go-github-com-google-gopacket.
  gnu: Add go-github-com-miekg-dns.
  gnu: Add go-github-com-nbrownus-go-metrics-prometheus.
  gnu: Add go-github-com-songgao-water.
  gnu: Add go-github-com-vishvananda-netns.
  gnu: Add go-github-com-vishvananda-netlink.
  gnu: Add go-google-golang-org-protobuf.
  gnu: Add go-github-com-matttproud-golang-protobuf-extensions.
  gnu: Add go-github-com-skip2-go-qrcode.
  gnu: Add nebula.

 gnu/packages/golang.scm     | 353 ++++++++++++++++++++++++++++++++++++
 gnu/packages/networking.scm |  79 ++++++++
 2 files changed, 432 insertions(+)


base-commit: ae85a472687c3987ceac7e8cd6f793b59dc75403

Comments

Sharlatan Hellseher Oct. 5, 2022, 6:30 p.m. UTC | #1
Hi,

This patch series would allow to add some other nice packages.

Is anything blocking them to be merged?

Regards,
Oleg
Simon Tournier Nov. 3, 2022, 9:32 a.m. UTC | #2
Hi Oleg,

On Wed, 05 Oct 2022 at 19:30, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:

> This patch series would allow to add some other nice packages.

Do the patches still apply?


> Is anything blocking them to be merged?

Well, interestingly the team Go has no member.

--8<---------------cut here---------------start------------->8---
id: go
name: Go team
description: <none>
scope: "gnu/packages/golang.scm" "guix/build/go-build-system.scm" "guix/build-system/go.scm" "guix/import/go.scm" "guix/scripts/import/go.scm" "tests/go.scm"
members:
--8<---------------cut here---------------end--------------->8---

Therefore, let CC teams core and mentors. :-)

Cheers,
simon
Dominic Martinez Nov. 3, 2022, 5:55 p.m. UTC | #3
There's an incompatibility with the version of protobuf used that 
breaks the package at runtime, and requires moving to the new 
protobuf. The patch is also generally out of date, so I need to 
work in updating/testing the packages.

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> Hi,
>
> This patch series would allow to add some other nice packages.
>
> Is anything blocking them to be merged?
>
> Regards,
> Oleg
Sharlatan Hellseher Feb. 12, 2024, 11:51 p.m. UTC | #4
Hi Dominic and  Alexey!

Thank you for the work and patience to bring Nebula to Guix.

I've shifted new packages into golang-xyz and move some from (gnu packages
syncthing) to prevent it's inclusion into (gnu packages networking).

Some of packages were already available so I've not include them.

- Modification applied [10/10]
  1. [X] go-github-com-anmitsu-go-shlex
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  2. [X] go-github-com-armon-go-radix
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  3. [X] go-github-com-cyberdelia-go-metrics-graphite
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  4. [X] go-github-com-google-gopacket
     - Added in 124ca1e500d65b57c802ee06423c1581a197ee1f by Hilton Chain <hako@ultrarare.space>
  5. [X] go-github-com-miekg-dns
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  6. [X] go-github-com-nbrownus-go-metrics-prometheus
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  7. [X] go-github-com-songgao-water
     - Adjust description
     - Placed to (gnu packages golang-xyz)
  8. [X] go-google-golang-org-protobuf
     - Added in 8835937ea5d708f322aa7ceabcf0d827f38168fc by  (unmatched-parenthesis <paren@disroot.org>
  9. [X] go-github-com-skip2-go-qrcode
     - Adjust description
     - Placed to (gnu packages golang-xyz)
     - Mentioned in https://issues.guix.gnu.org/62284
  10. [X] go-dario-cat-mergo

Pushed as 0969cb0b48..ace1785c5d to master.

--
Oleg