diff mbox series

[bug#54335,01/14] gnu: Add go-github-com-anmitsu-go-shlex.

Message ID 20220311031849.12681-1-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:18 a.m. UTC
* gnu/packages/golang.scm (go-github-com-anmitsu-go-shlex): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M March 11, 2022, 4:09 p.m. UTC | #1
Dominic Martinez schreef op do 10-03-2022 om 22:18 [-0500]:
> +(define-public go-github-com-anmitsu-go-shlex
> +  (package
> +    (name "go-github-com-anmitsu-go-shlex")
> +    (version "0.0.0-20200514113438-38f4b401e2be")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/anmitsu/go-shlex")
> +               (commit (go-version->git-ref version))))

What's the difference with go-github-com-flynn-archive-go-shlex?
Are they related?

Greetings,
Maxime.
Dominic Martinez March 11, 2022, 8:28 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> What's the difference with go-github-com-flynn-archive-go-shlex?
> Are they related?

The author of go-github-com-flynn-archive-go-shlex marked it as 
unmaintained and it hasn't seen development since 
2015. go-github-com-anmitsu-go-shlex is currently maintained.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7080bb6e24..7d796c7620 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9752,3 +9752,25 @@  (define-public go-github-com-go-chi-chi-v5
      "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
 decompose request handling into many smaller layers.")
     (license license:expat)))
+
+(define-public go-github-com-anmitsu-go-shlex
+  (package
+    (name "go-github-com-anmitsu-go-shlex")
+    (version "0.0.0-20200514113438-38f4b401e2be")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/anmitsu/go-shlex")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "17iz68yzbnr7y4s493asbagbv79qq8hvl2pkxvm6bvdkgphj8w1g"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/anmitsu/go-shlex"))
+    (home-page "https://github.com/anmitsu/go-shlex")
+    (synopsis "Simple shell-like lexical analyzer for Go")
+    (description
+      "@code{go-github-com-anmitsu-go-shlex} provides a simple lexical
+analysis like the Unix shell.")
+    (license license:expat)))