diff mbox series

[bug#42465,09/10] gnu: Add python-flake8-pyi.

Message ID 20200721115633.6088-9-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-pyi): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:15 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-flake8-pyi): New variable.

[...]
  
> +(define-public python-flake8-pyi
> +  (package
> +    (name "python-flake8-pyi")
> +    (version "20.5.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "flake8-pyi" version))
> +       (sha256
> +        (base32
> +         "1zpq4s9kp8w95pccmhhyyx1ff2zhnidcf1zb3xs46lzcx9plvnzk"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-attrs" ,python-attrs)
> +       ("python-flake8" ,python-flake8)
> +       ("python-pyflakes" ,python-pyflakes)))
> +    (home-page "https://github.com/ambv/flake8-pyi")
> +    (synopsis
> +      "A plugin for Flake8 that provides specializations for type hinting stub files.")

No punctuation or article (you probably got that by now).  :-)

> +    (description
> +     "A plugin for Flake8 that provides specializations for type hinting stub files,
> +especially interesting for linting typeshed.  1) Adds the .pyi extension to
> +the default value of the --filename command-line argument to Flake8.  This means
> +stubs are linted by default with this plugin enabled, without needing to explicitly list
> +every file.  2) Modifies PyFlakes runs for .pyi files to defer checking type annotation
> +expressions after the entire file has been read.  This enables support for first-class
> +forward references that stub files use.")

And full sentence, i.e. "This package contains a plugin ...".  Also
@file{.pyi}.

The 1) and 2) reads "weird" to me, maybe they can be cut off and just
use the text?  Or perhaps they should be on separate lines, perhaps with
@enumerate or similar?
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dd1e78d2e0..1d4199eb14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7957,6 +7957,35 @@  plugins that intend to support Flake8 2.x and 3.x simultaneously.")
 (define-public python2-flake8-polyfill
   (package-with-python2 python-flake8-polyfill))
 
+(define-public python-flake8-pyi
+  (package
+    (name "python-flake8-pyi")
+    (version "20.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-pyi" version))
+       (sha256
+        (base32
+         "1zpq4s9kp8w95pccmhhyyx1ff2zhnidcf1zb3xs46lzcx9plvnzk"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-flake8" ,python-flake8)
+       ("python-pyflakes" ,python-pyflakes)))
+    (home-page "https://github.com/ambv/flake8-pyi")
+    (synopsis
+      "A plugin for Flake8 that provides specializations for type hinting stub files.")
+    (description
+     "A plugin for Flake8 that provides specializations for type hinting stub files,
+especially interesting for linting typeshed.  1) Adds the .pyi extension to
+the default value of the --filename command-line argument to Flake8.  This means
+stubs are linted by default with this plugin enabled, without needing to explicitly list
+every file.  2) Modifies PyFlakes runs for .pyi files to defer checking type annotation
+expressions after the entire file has been read.  This enables support for first-class
+forward references that stub files use.")
+    (license license:expat)))
+
 (define-public python-mistune
   (package
     (name "python-mistune")