diff mbox series

[bug#42465,07/10] gnu: Add python-hypothesmith.

Message ID 20200721115633.6088-7-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/check.scm (python-hypothesmith): New variable.
---
 gnu/packages/check.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:09 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/check.scm (python-hypothesmith): New variable.

[...]
  
> +(define-public python-hypothesmith
> +  (package
> +    (name "python-hypothesmith")
> +    (version "0.1.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "hypothesmith" version))
> +       (sha256
> +        (base32
> +         "09331sspknv459xcyn1k0lx5flqlc6gmnwp9370pfvg4kg1zmss6"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-hypothesis" ,python-hypothesis)
> +       ("python-lark-parser" ,python-lark-parser)
> +       ("python-libcst" ,python-libcst)))
> +    (home-page "https://github.com/Zac-HD/hypothesmith")
> +    (synopsis "Strategies for generating Python programs.")

No '.' at the end of synopsis.

> +    (description
> +     "Hypothesis strategies for generating Python programs, something like CSmith.  This
> +is definitely pre-alpha, but if you want to play with it feel free!")

This should be a full sentence, i.e. "This package contains hypothesis
strategies for [...]".  Can you define "CSmith"?

Also I think the other sentence can be omitted.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a3608e4125..817bdb4cd9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1840,6 +1840,29 @@  seamlessly into your existing Python unit testing work flow.")
        `(("python2-enum34" ,python2-enum34)
          ,@(package-propagated-inputs hypothesis))))))
 
+(define-public python-hypothesmith
+  (package
+    (name "python-hypothesmith")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hypothesmith" version))
+       (sha256
+        (base32
+         "09331sspknv459xcyn1k0lx5flqlc6gmnwp9370pfvg4kg1zmss6"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-lark-parser" ,python-lark-parser)
+       ("python-libcst" ,python-libcst)))
+    (home-page "https://github.com/Zac-HD/hypothesmith")
+    (synopsis "Strategies for generating Python programs.")
+    (description
+     "Hypothesis strategies for generating Python programs, something like CSmith.  This
+is definitely pre-alpha, but if you want to play with it feel free!")
+    (license license:mpl2.0)))
+
 (define-public python-lit
   (package
     (name "python-lit")