diff mbox series

[bug#42465,02/10] gnu: python-hypothesis: Update to 5.20.0.

Message ID 20200721115633.6088-2-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/check.scm (python-hypothesis): Update to 5.20.0.
---
 gnu/packages/check.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Marius Bakke July 25, 2020, 3:52 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/check.scm (python-hypothesis): Update to 5.20.0.

This can not be applied on 'master' because Hypothesis has 6261
dependent packages:

$ ./pre-inst-env guix refresh -l python-hypothesis
Building the following 2211 packages would ensure 6261 dependent
packages are rebuilt: [...]

If it is necessary for the remainder of this series, you can add a
different variable with the new hypothesis like so:

(define-public python-hypothesis-5.20
  (package
    (inherit python-hypothesis)
    (version "5.20")
    (source ...)))

And then add 'python-hypothesis-5.20' to native-inputs in the packages
that need it.

Can you look into it?
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 661ed65e53..a3608e4125 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1801,13 +1801,13 @@  instantly.")
 (define-public python-hypothesis
   (package
     (name "python-hypothesis")
-    (version "5.4.1")
+    (version "5.20.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "hypothesis" version))
               (sha256
                (base32
-                "0zn09bn6hadk4vxl6jy8bkjr5fz8mrhin3z46w7pq5qgbaycr89p"))))
+                "0h1wy6wdcbgidqw5spm0lndlj77l6d5na5z2cxy04g4yp5m9v9jh"))))
     (build-system python-build-system)
     (arguments
      ;; XXX: Tests are not distributed with the PyPI archive.