diff mbox series

[bug#42465,06/10] gnu: Add python-lark-parser.

Message ID 20200721115633.6088-6-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-lark-parser): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:05 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-lark-parser): New variable.

[...]

> +    (synopsis "A modern parsing library for Python")

Maybe "Multi-language parser for Python"?  At least the 'A' should go. 

> +    (description
> +     "Lark is a parser built with a focus on ergonomics, performance and resilience.
> +Lark can parse all context-free languages.  That means it is capable of parsing almost
> +any programming language out there, and to some degree most natural languages too.")

Heh, cool stuff!  :-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b462a42f0..533e2f6421 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12274,6 +12274,25 @@  in Python.  It allows you to declare the libraries your project depends on and
 it will manage (install/update) them for you.")
     (license license:expat)))
 
+(define-public python-lark-parser
+  (package
+    (name "python-lark-parser")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "lark-parser" version))
+              (sha256
+               (base32
+                "1kd61asrb3h9spgsj4bslfbgp8q4271sw3hblk6f2vbbblv8jxcy"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/lark-parser/lark")
+    (synopsis "A modern parsing library for Python")
+    (description
+     "Lark is a parser built with a focus on ergonomics, performance and resilience.
+Lark can parse all context-free languages.  That means it is capable of parsing almost
+any programming language out there, and to some degree most natural languages too.")
+    (license license:expat)))
+
 (define-public python-libcst
   (package
     (name "python-libcst")