diff mbox series

[bug#42465,08/10] gnu: Add python-flake8-bugbear.

Message ID 20200721115633.6088-8-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-bugbear): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:13 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-flake8-bugbear): New variable.

[...]
  
> +(define-public python-flake8-bugbear
> +  (package
> +    (name "python-flake8-bugbear")
> +    (version "20.1.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "flake8-bugbear" version))
> +       (sha256
> +        (base32
> +         "0qiihb242fygzyrfynq913ak7cdmx8mcac9c0zk3y5gv16qf80mx"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     `(("python-hypothesis" ,python-hypothesis)
> +       ("python-hypothesmith" ,python-hypothesmith)))

I realize now that hypothesmith is probably a hypothesis plugin?  In
that case it should not propagate hypothesis IMO.

> +    (propagated-inputs
> +     `(("python-attrs" ,python-attrs)
> +       ("python-flake8" ,python-flake8)))
> +    (home-page "https://github.com/PyCQA/flake8-bugbear")
> +    (synopsis
> +      "A plugin for Flake8 finding likely bugs and design problems in your program")

Just "Flake8 plugin for [...]".

> +    (description
> +     "A plugin for Flake8 finding likely bugs and design problems in your program.
> +Contains warnings that don't belong in pyflakes and pycodestyle.  It is felt that
> +these lints don't belong in the main Python tools as they are very opinionated and
> +do not have a PEP or standard behind them.")

Please use full sentences, i.e. "This package contains a plugin for
Flake8 ..." and "It contains warnings that ...".

I don't really understand the last sentence.  Who feels this?  Can we
remove it?  :-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 533e2f6421..dd1e78d2e0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7886,6 +7886,34 @@  complexity of Python source code.")
        ("python-pyflakes" ,python-pyflakes-1.2)
        ("python-mccabe" ,python-mccabe)))))
 
+(define-public python-flake8-bugbear
+  (package
+    (name "python-flake8-bugbear")
+    (version "20.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-bugbear" version))
+       (sha256
+        (base32
+         "0qiihb242fygzyrfynq913ak7cdmx8mcac9c0zk3y5gv16qf80mx"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-hypothesmith" ,python-hypothesmith)))
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-flake8" ,python-flake8)))
+    (home-page "https://github.com/PyCQA/flake8-bugbear")
+    (synopsis
+      "A plugin for Flake8 finding likely bugs and design problems in your program")
+    (description
+     "A plugin for Flake8 finding likely bugs and design problems in your program.
+Contains warnings that don't belong in pyflakes and pycodestyle.  It is felt that
+these lints don't belong in the main Python tools as they are very opinionated and
+do not have a PEP or standard behind them.")
+    (license license:expat)))
+
 (define-public python-flake8-polyfill
   (package
     (name "python-flake8-polyfill")