diff mbox series

[bug#42465,04/10] gnu: Add python-typing-inspect.

Message ID 20200721115633.6088-4-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: Add python-mypy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 21, 2020, 11:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-typing-inspect): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Marius Bakke July 25, 2020, 3:58 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-typing-inspect): New variable.

[...]
  
> +(define-public python-typing-inspect
> +  (package
> +    (name "python-typing-inspect")
> +    (version "0.6.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "typing_inspect" version))
> +              (sha256
> +               (base32
> +                "1dzs9a1pr23dhbvmnvms2jv7l7jk26023g5ysf0zvnq8b791s6wg"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-mypy-extensions" ,python-mypy-extensions)
> +       ("python-typing-extensions" ,python-typing-extensions)))
> +    (home-page "https://github.com/ilevkivskyi/typing_inspect")
> +    (synopsis
> +     "Defines experimental API for runtime inspection of types defined in the Python
> +standard typing module")

Just 'API for inspection of types in the Python @code{typing} module'.

> +    (description
> +     "The typing_inspect module defines experimental API for runtime inspection of types
> +defined in the Python standard typing module. Works with typing version 3.7.4 and
> +later.")

@code{typing_inspect}.  Also two spaces between sentences (guix lint
will warn about this).  Although in this case I think we can cut the
other sentence completely, as I presume it will get outdated soon.
WDYT?
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 893506b5c3..2293a16ecc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12274,6 +12274,30 @@  in Python.  It allows you to declare the libraries your project depends on and
 it will manage (install/update) them for you.")
     (license license:expat)))
 
+(define-public python-typing-inspect
+  (package
+    (name "python-typing-inspect")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "typing_inspect" version))
+              (sha256
+               (base32
+                "1dzs9a1pr23dhbvmnvms2jv7l7jk26023g5ysf0zvnq8b791s6wg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mypy-extensions" ,python-mypy-extensions)
+       ("python-typing-extensions" ,python-typing-extensions)))
+    (home-page "https://github.com/ilevkivskyi/typing_inspect")
+    (synopsis
+     "Defines experimental API for runtime inspection of types defined in the Python
+standard typing module")
+    (description
+     "The typing_inspect module defines experimental API for runtime inspection of types
+defined in the Python standard typing module. Works with typing version 3.7.4 and
+later.")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")