diff mbox series

[bug#40601,09/28] guix-install.sh: Fix requirements.

Message ID 20200517171725.732-9-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
There's no usage of "tr" in the script, whereas tar is used.

* etc/guix-install.sh (REQUIRE): Change tr to tar, add ln, remove
readlink & dirname.
---
 etc/guix-install.sh | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index a56e0ec7b2..19883b89ae 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -33,8 +33,6 @@  set -e
 [ "$UID" -eq 0 ] || { echo "This script must be run as root."; exit 1; }
 
 REQUIRE=(
-    "dirname"
-    "readlink"
     "wget"
     "gpg"
     "grep"
@@ -42,6 +40,7 @@  REQUIRE=(
     "sed"
     "sort"
     "getent"
+    "ln"
     "mktemp"
     "rm"
     "chmod"
@@ -49,7 +48,7 @@  REQUIRE=(
     "groupadd"
     "tail"
     "realpath"
-    "tr"
+    "tar"
     "xz"
 )