diff mbox series

[bug#40601,11/28] guix-install.sh: Use a variable for GPG key URL.

Message ID 20200517171725.732-11-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
* etc/guix-install.sh (OPENPGP_SIGNING_KEY_URL): Add new variable.
(chk_gpg_keyring): Use it here.
---
 etc/guix-install.sh | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index d2e44e98b2..043357d9c4 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -59,6 +59,7 @@  INF="[ INFO ] "
 DEBUG=0
 GNU_URL="https://ftp.gnu.org/gnu/guix/"
 OPENPGP_SIGNING_KEY_ID="3CE464558A84FDC69DB40CFB090B11993D9AEBB5"
+OPENPGP_SIGNING_KEY_URL="https://sv.gnu.org/people/viewgpg.php?user_id=15145"
 
 # This script needs to know where root's home directory is.  However, we
 # cannot simply use the HOME environment variable, since there is no guarantee
@@ -112,7 +113,7 @@  chk_gpg_keyring()
     # systems where gpg has never been used, causing errors and confusion.
     gpg --dry-run --list-keys ${OPENPGP_SIGNING_KEY_ID} >/dev/null 2>&1 || {
         _err "${ERR}Missing OpenPGP public key.  Fetch it with this command:";
-        echo "  wget https://sv.gnu.org/people/viewgpg.php?user_id=15145 -qO - | gpg --import -";
+        echo "  wget ${OPENPGP_SIGNING_KEY_URL} -qO - | gpg --import -";
         exit 1;
     }
 }