diff mbox series

[bug#40601,15/28] guix-install.sh, guix-binary tarball: Handle openrc-based foreign distributions.

Message ID 20200517171725.732-15-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
* .gitignore: Add etc/openrc/guix-daemon.in.
* etc/guix-install.sh (chk_init_sys): Add case to detect openrc.
(sys_enable_guix_daemon): Add case to setup guix-daemon within openrc.
* etc/openrc/guix-daemon.in: New file...
* nix/local.mk (etc/openrc/guix-daemon): Add target to generate
etc/openrc/guix-daemon from etc/openrc/guix-daemon.in.
(CLEANFILES): ...add it here. (nodist_openrcservice_DATA): New variable...
(openrcservicedir): New variable. (EXTRA_DIST): Add etc/openrc/guix-daemon.in.
---
 .gitignore                |  1 +
 etc/guix-install.sh       | 14 ++++++++++++++
 etc/openrc/guix-daemon.in | 14 ++++++++++++++
 nix/local.mk              | 13 +++++++++++++
 4 files changed, 42 insertions(+)
 create mode 100644 etc/openrc/guix-daemon.in
diff mbox series

Patch

diff --git a/.gitignore b/.gitignore
index 89a2c89e1e..6cd9fb4f17 100644
--- a/.gitignore
+++ b/.gitignore
@@ -72,6 +72,7 @@ 
 /etc/guix-publish.conf
 /etc/guix-publish.service
 /etc/init.d/guix-daemon
+/etc/openrc/guix-daemon
 /etc/runit/run
 /guix-daemon
 /guix/config.scm
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index b5e8416610..1c22ae95ee 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -149,6 +149,10 @@  chk_init_sys()
         _msg "${INF}init system is: systemd"
         INIT_SYS="systemd"
         return 0
+    elif [[ $(rc -V 2>/dev/null) =~ OpenRC ]]; then
+        _msg "${INF}init system is: openrc"
+        INIT_SYS="openrc"
+        return 0
     elif [[ -f /etc/init.d/cron && ! -h /etc/init.d/cron ]]; then
         _msg "${INF}init system is: sysv-init"
         INIT_SYS="sysv-init"
@@ -396,6 +400,16 @@  sys_enable_guix_daemon()
               ln -s /etc/sv/guix-daemon /etc/runit/runsvdir/default/; } &&
                 _msg "${PAS}enabled Guix daemon via runit"
             ;;
+        openrc)
+            { mkdir -p /etc/init.d;
+              cp "${ROOT_HOME}/.config/guix/current/lib/openrc/guix-daemon/guix-daemon" \
+                 /etc/init.d/guix-daemon;
+              chmod 755 /etc/init.d/guix-daemon;
+
+              rc-update add guix-daemon default &&
+              rc-service guix-daemon start; } &&
+                _msg "${PAS}enabled Guix daemon via openrc"
+            ;;
         sysv-init)
             { mkdir -p /etc/init.d;
               cp "${ROOT_HOME}/.config/guix/current/etc/init.d/guix-daemon" \
diff --git a/etc/openrc/guix-daemon.in b/etc/openrc/guix-daemon.in
new file mode 100644
index 0000000000..9641dcfad6
--- /dev/null
+++ b/etc/openrc/guix-daemon.in
@@ -0,0 +1,14 @@ 
+#!/sbin/openrc-run
+
+# This is a service script file for the openrc init system to launch
+# 'guix-daemon'.  Copy it as /etc/init.d/guix-daemon to have 'guix-daemon'
+# automatically started.
+
+command=@localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix-daemon
+command_args=--build-users-group=guixbuild
+command_background=true
+pidfile=/run/guix-daemon.pid
+
+GUIX_LOCPATH=@localstatedir@/guix/profiles/per-user/root/guix-profile/lib/locale
+LC_ALL=en_US.utf8
+
diff --git a/nix/local.mk b/nix/local.mk
index 582ff16168..9d6f92ebc8 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -187,6 +187,17 @@  etc/runit/run: etc/runit/run.in		\
                "$<" > "$@.tmp";         \
         mv "$@.tmp" "$@"
 
+# The service script for openrc.
+openrcservicedir = $(libdir)/openrc/guix-daemon
+nodist_openrcservice_DATA = etc/openrc/guix-daemon
+
+etc/openrc/guix-daemon: etc/openrc/guix-daemon.in		\
+			$(top_builddir)/config.status
+	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";   \
+        $(SED) -e 's|@''localstatedir''@|$(localstatedir)|' <   \
+               "$<" > "$@.tmp";         \
+        mv "$@.tmp" "$@"
+
 # The '.conf' jobs for Upstart.
 upstartjobdir = $(libdir)/upstart/system
 nodist_upstartjob_DATA = etc/guix-daemon.conf etc/guix-publish.conf
@@ -202,6 +213,7 @@  CLEANFILES +=					\
   $(nodist_systemdservice_DATA)			\
   $(nodist_upstartjob_DATA)			\
   $(nodist_runitservice_DATA)			\
+  $(nodist_openrcservice_DATA)			\
   $(nodist_sysvinitservice_DATA)
 
 EXTRA_DIST +=					\
@@ -212,6 +224,7 @@  EXTRA_DIST +=					\
   etc/guix-publish.service.in			\
   etc/guix-publish.conf.in			\
   etc/runit/run.in				\
+  etc/openrc/guix-daemon.in			\
   etc/init.d/guix-daemon.in
 
 if CAN_RUN_TESTS