diff mbox series

[bug#40601,18/28] Replace the use of "which" by "command -v"

Message ID 20200517171725.732-18-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
---
 etc/guix-install.sh | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index e350fdb052..596ceb5b39 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -38,7 +38,6 @@  REQUIRE=(
     "wget"
     "gpg"
     "grep"
-    "which"
     "sed"
     "sort"
     "getent"
@@ -329,12 +328,13 @@  sys_create_build_user()
 
     _debug "--- [ $FUNCNAME ] ---"
 
+    NOLOGIN_SHELL="$(command -v nologin)"
     for i in $(seq -w 1 10); do
         if getent passwd "guixbuilder${i}" >/dev/null 2>&1; then
             if command -v usermod &>/dev/null; then
                 _msg "${INF}user is already in the system, resetting"
                 usermod -g guixbuild -G guixbuild           \
-                        -d /var/empty -s "$(which nologin)" \
+                        -d /var/empty -s "${NOLOGIN_SHELL}" \
                         -c "Guix build user $i"             \
                         "guixbuilder${i}"
             else
@@ -343,12 +343,12 @@  sys_create_build_user()
         else
             if command -v useradd &>/dev/null; then
                 useradd -g guixbuild -G guixbuild           \
-                        -d /var/empty -s "$(which nologin)" \
+                        -d /var/empty -s "${NOLOGIN_SHELL}" \
                         -c "Guix build user $i" --system    \
                         "guixbuilder${i}"
                 _msg "${PAS}user added <guixbuilder${i}>"
             elif command -v adduser &>/dev/null; then
-                adduser -G guixbuild -h /var/empty -s "$(which nologin)" \
+                adduser -G guixbuild -h /var/empty -s "${NOLOGIN_SHELL}" \
                         -H -S "guixbuilder${i}"
                 _msg "${PAS}user added <guixbuilder${i}>"
             else