diff mbox series

[bug#40601,24/28] Remove some "[[" bashisms

Message ID 20200517171725.732-24-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
---
 etc/guix-install.sh | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 431790709a..cd33bf55bf 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -216,7 +216,7 @@  guix_get_bin_list()
 
     default_ver="guix-binary-${latest_ver}.${ARCH_OS}"
 
-    if [[ "${#bin_ver_ls}" -ne "0" ]]; then
+    if [ "${#bin_ver_ls}" -ne 0 ]; then
         _msg "${PAS}Release for your system: ${default_ver}"
     else
         _err "${ERR}Could not obtain list of Guix releases."
@@ -241,7 +241,7 @@  guix_get_bin()
         _PROGRESS_OPT="-q --show-progress" || _PROGRESS_OPT=""
     wget $_PROGRESS_OPT -P "${dl_path}" "${url}/${bin_ver}.tar.xz" "${url}/${bin_ver}.tar.xz.sig"
 
-    if [[ "$?" -eq 0 ]]; then
+    if [ "$?" -eq 0 ]; then
        _msg "${PAS}download completed."
     else
         _err "${ERR}could not download ${url}/${bin_ver}.tar.xz."
@@ -250,7 +250,7 @@  guix_get_bin()
 
     pushd "${dl_path}" >/dev/null
     gpg --verify "${bin_ver}.tar.xz.sig" >/dev/null 2>&1
-    if [[ "$?" -eq 0 ]]; then
+    if [ "$?" -eq 0 ]; then
         _msg "${PAS}Signature is valid."
         popd >/dev/null
     else
@@ -275,7 +275,7 @@  sys_create_store()
     tar x -f "${pkg}" "${TAROPTS[@]}" &&
     _msg "${PAS}unpacked archive"
 
-    if [[ -e "/var/guix" || -e "/gnu" ]]; then
+    if [ -e "/var/guix" ] || [ -e "/gnu" ]; then
         _err "${ERR}A previous Guix installation was found.  Refusing to overwrite."
         exit 1
     else