diff mbox series

[bug#40601,07/28] guix-install.sh: Move code in a new function.

Message ID 20200517171725.732-7-vincent.legoll@gmail.com
State Under Review
Delegated to: Christopher Baines
Headers show
Series [bug#40601,01/28] nix/local.mk: Add missing comment to sysvinit section. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vincent Legoll May 17, 2020, 5:17 p.m. UTC
* etc/guix-install.sh (sys_enable_guix_daemon): Move code from here...
(sys_make_guix_available): ...to this new function, fixing whitespace...
(main): ...and call it here.
---
 etc/guix-install.sh | 25 ++++++++++++++++---------
 1 file changed, 16 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 078aa4a781..225cf532b8 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -330,16 +330,8 @@  sys_create_build_user()
 sys_enable_guix_daemon()
 { # Run the daemon, and set it to automatically start on boot.
 
-    local info_path
-    local local_bin
-    local var_guix
-
     _debug "--- [ $FUNCNAME ] ---"
 
-    info_path="/usr/local/share/info"
-    local_bin="/usr/local/bin"
-    var_guix="/var/guix/profiles/per-user/root/current-guix"
-
     case "$INIT_SYS" in
         upstart)
             { initctl reload-configuration;
@@ -391,11 +383,25 @@  sys_enable_guix_daemon()
             echo "  ${ROOT_HOME}/.config/guix/current/bin/guix-daemon --build-users-group=guixbuild"
             ;;
     esac
+}
+
+sys_make_guix_available()
+{ # add guix into PATH
+
+    local info_path
+    local local_bin
+    local var_guix
+
+    _debug "--- [ $FUNCNAME ] ---"
+
+    info_path="/usr/local/share/info"
+    local_bin="/usr/local/bin"
+    var_guix="/var/guix/profiles/per-user/root/current-guix"
 
     _msg "${INF}making the guix command available to other users"
 
     [ -e "$local_bin" ] || mkdir -p "$local_bin"
-    ln -sf "${var_guix}/bin/guix"  "$local_bin"
+    ln -sf "${var_guix}/bin/guix" "$local_bin"
 
     [ -e "$info_path" ] || mkdir -p "$info_path"
     for i in ${var_guix}/share/info/*; do
@@ -505,6 +511,7 @@  main()
     sys_create_store "${TARBALL}" "${tmp_path}"
     sys_create_build_user
     sys_enable_guix_daemon
+    sys_make_guix_available
     sys_authorize_build_farms
     sys_create_init_profile