diff mbox series

[bug#36477,04/31] gnu: tk: Fix cross-compilation.

Message ID 20190708095913.3460-5-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:58 a.m. UTC
* gnu/packages/tcl.scm (tk)[arguments]: Add configure flags to fix
cross-compilation.
---
 gnu/packages/tcl.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Marius Bakke July 8, 2019, 5:42 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/tcl.scm (tk)[arguments]: Add configure flags to fix
> cross-compilation.
> ---
>  gnu/packages/tcl.scm | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
> index fc955cf649..df0f0e3a5c 100644
> --- a/gnu/packages/tcl.scm
> +++ b/gnu/packages/tcl.scm
> @@ -185,9 +185,16 @@ X11 GUIs.")
>                                           "/lib -lfontconfig")))
>                         #t))))
>  
> -       #:configure-flags (list (string-append "--with-tcl="
> -                                              (assoc-ref %build-inputs "tcl")
> -                                              "/lib"))
> +       #:configure-flags
> +       (list (string-append "--with-tcl="
> +                            (assoc-ref %build-inputs "tcl")
> +                            "/lib")
> +             ;; This is needed when cross-compiling, see:
> +             ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
> +             ,@(if (%current-target-system)
> +                   '("tcl_cv_strtod_buggy=1"
> +                     "ac_cv_func_strtod=yes")
> +                   '()))

LGTM (though I guess not very useful without the Python cross fix?).
diff mbox series

Patch

diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index fc955cf649..df0f0e3a5c 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -185,9 +185,16 @@  X11 GUIs.")
                                          "/lib -lfontconfig")))
                        #t))))
 
-       #:configure-flags (list (string-append "--with-tcl="
-                                              (assoc-ref %build-inputs "tcl")
-                                              "/lib"))
+       #:configure-flags
+       (list (string-append "--with-tcl="
+                            (assoc-ref %build-inputs "tcl")
+                            "/lib")
+             ;; This is needed when cross-compiling, see:
+             ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
+             ,@(if (%current-target-system)
+                   '("tcl_cv_strtod_buggy=1"
+                     "ac_cv_func_strtod=yes")
+                   '()))
 
        ;; The tests require a running X server, so we just skip them.
        #:tests? #f))