diff mbox series

[bug#36477,23/31] gnu: help2man: Fix cross-compilation.

Message ID 20190708095913.3460-24-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:59 a.m. UTC
* gnu/packages/man.scm (help2man)[inputs]: Turn into ...
[native-inputs]: ... that.
---
 gnu/packages/man.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Marius Bakke July 8, 2019, 6:15 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/man.scm (help2man)[inputs]: Turn into ...
> [native-inputs]: ... that.

help2man references perl at runtime, should it not be in both inputs and
native-inputs?
Mathieu Othacehe July 25, 2019, 2:28 p.m. UTC | #2
> help2man references perl at runtime, should it not be in both inputs and
> native-inputs?

help2man being a perl script I guess you are right.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 04c800e95f..6b5de3d033 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -210,7 +210,7 @@  Linux kernel and C library interfaces employed by user-space programs.")
     (build-system gnu-build-system)
     (arguments `(;; There's no `check' target.
                  #:tests? #f))
-    (inputs
+    (native-inputs
      `(("perl" ,perl)
        ;; TODO: Add these optional dependencies.
        ;; ("perl-LocaleGettext" ,perl-LocaleGettext)