diff mbox series

[bug#36477,31/31] gnu: glibc-utf8-locales: Fix cross-compilation.

Message ID 20190708095913.3460-32-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:59 a.m. UTC
* gnu/packages/base.scm (glibc-utf8-locales)[inputs]: Move to ...
[native-inputs]: ... here, in order to fix cross-compilation.
* gnu/packages/commencement.scm (glibc-utf8-locales-final)[inputs]: Move to ...
[native-inputs]: ... here, in order to fix cross-compilation.
---
 gnu/packages/base.scm         |  4 ++--
 gnu/packages/commencement.scm | 11 ++++++-----
 2 files changed, 8 insertions(+), 7 deletions(-)

Comments

Marius Bakke July 8, 2019, 6:37 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/base.scm (glibc-utf8-locales)[inputs]: Move to ...
> [native-inputs]: ... here, in order to fix cross-compilation.
> * gnu/packages/commencement.scm (glibc-utf8-locales-final)[inputs]: Move to ...
> [native-inputs]: ... here, in order to fix cross-compilation.

Is the glibc locale data really architecture-independent?

Is it not sufficient to have only "gzip" native here?
Mathieu Othacehe July 29, 2019, 2:54 p.m. UTC | #2
Hello Marius,

> Is the glibc locale data really architecture-independent?

I compared locale data built natively for intel and arm and they are
identical. However all those platforms have the same endianess. I don't
know what would happend on a big endian platform.

>
> Is it not sufficient to have only "gzip" native here?

No because we need to use the localedef binary from the native glibc.

Ideally, we would need to pass some kind of --target to this binary but
it doesn't seem to be supported :(.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 15f35009a9..216a2f1591 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1143,8 +1143,8 @@  to the @code{share/locale} sub-directory of this package.")
                                ;; tests---e.g., in Guile's i18n tests.
                                '("de_DE" "el_GR" "en_US" "fr_FR" "tr_TR"))
                      #t))))
-    (inputs `(("glibc" ,glibc)
-              ("gzip" ,gzip)))
+    (native-inputs `(("glibc" ,glibc)
+                     ("gzip" ,gzip)))
     (synopsis "Small sample of UTF-8 locales")
     (description
      "This package provides a small sample of UTF-8 locales mostly useful in
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index a8ec677cee..c0345aa967 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -881,11 +881,12 @@  exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
   ;; function.)
   (package
     (inherit glibc-utf8-locales)
-    (inputs `(("glibc" ,glibc-final)
-              ("gzip"
-               ,(package-with-explicit-inputs gzip %boot4-inputs
-                                              (current-source-location)
-                                              #:guile %bootstrap-guile))))))
+    (native-inputs
+     `(("glibc" ,glibc-final)
+       ("gzip"
+        ,(package-with-explicit-inputs gzip %boot4-inputs
+                                       (current-source-location)
+                                       #:guile %bootstrap-guile))))))
 
 (define-public ld-wrapper
   ;; The final 'ld' wrapper, which uses the final Guile and Binutils.