diff mbox series

[bug#36477,03/31] gnu: tcl: Fix cross-compilation.

Message ID 20190708095913.3460-4-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:58 a.m. UTC
* gnu/packages/tcl.scm (tcl)[arguments]: Add configure flags to fix
cross-compilation.
---
 gnu/packages/tcl.scm | 15 +++++++++++----
 1 file changed, 11 insertions(+), 4 deletions(-)

Comments

Marius Bakke July 8, 2019, 5:41 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/tcl.scm (tcl)[arguments]: Add configure flags to fix
> cross-compilation.
> ---
>  gnu/packages/tcl.scm | 15 +++++++++++----
>  1 file changed, 11 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
> index 4840ac4e10..fc955cf649 100644
> --- a/gnu/packages/tcl.scm
> +++ b/gnu/packages/tcl.scm
> @@ -53,7 +53,7 @@
>                  "0sprsg7wnraa4cbwgbcliylm6p0rspfymxn8ww02pr4ca70v0g64"))))
>      (build-system gnu-build-system)
>      (arguments
> -     '(#:phases (modify-phases %standard-phases
> +     `(#:phases (modify-phases %standard-phases
>                    (add-before 'configure 'pre-configure
>                      (lambda _ (chdir "unix") #t))
>                   (add-after 'install 'install-private-headers
> @@ -73,9 +73,16 @@
>         ;; PREFIX/share/man.  The 'validate-documentation-location' phase is
>         ;; not able to fix this up because the default install populates both
>         ;; PREFIX/man and PREFIX/share/man.
> -       #:configure-flags (list (string-append "--mandir="
> -                                              (assoc-ref %outputs "out")
> -                                              "/share/man"))
> +       #:configure-flags
> +       (list (string-append "--mandir="
> +                            (assoc-ref %outputs "out")
> +                            "/share/man")
> +             ;; This is needed when cross-compiling, see:
> +             ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
> +             ,@(if (%current-target-system)
> +                   '("tcl_cv_strtod_buggy=1"
> +                     "ac_cv_func_strtod=yes")
> +                   '()))

OK!
diff mbox series

Patch

diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 4840ac4e10..fc955cf649 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -53,7 +53,7 @@ 
                 "0sprsg7wnraa4cbwgbcliylm6p0rspfymxn8ww02pr4ca70v0g64"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
+     `(#:phases (modify-phases %standard-phases
                   (add-before 'configure 'pre-configure
                     (lambda _ (chdir "unix") #t))
                  (add-after 'install 'install-private-headers
@@ -73,9 +73,16 @@ 
        ;; PREFIX/share/man.  The 'validate-documentation-location' phase is
        ;; not able to fix this up because the default install populates both
        ;; PREFIX/man and PREFIX/share/man.
-       #:configure-flags (list (string-append "--mandir="
-                                              (assoc-ref %outputs "out")
-                                              "/share/man"))
+       #:configure-flags
+       (list (string-append "--mandir="
+                            (assoc-ref %outputs "out")
+                            "/share/man")
+             ;; This is needed when cross-compiling, see:
+             ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
+             ,@(if (%current-target-system)
+                   '("tcl_cv_strtod_buggy=1"
+                     "ac_cv_func_strtod=yes")
+                   '()))
 
        ;; XXX: There are a few test failures (related to HTTP, most
        ;; likely related to name resolution), but that doesn't cause