diff mbox series

[bug#36477,12/31] gnu: cmake: Extend CMAKE_PREFIX_PATH to non-native inputs.

Message ID 20190708095913.3460-13-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:58 a.m. UTC
* gnu/packages/cmake.scm (cmake)[native-search-paths]: Turn to search-paths.
This allows libraries using cmake functions "find_file" or "find_library" to
search in non-native inputs while cross-compiling.
---
 gnu/packages/cmake.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Marius Bakke July 8, 2019, 5:47 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/cmake.scm (cmake)[native-search-paths]: Turn to search-paths.
> This allows libraries using cmake functions "find_file" or "find_library" to
> search in non-native inputs while cross-compiling.

Does this still do the right thing in a native context?
Mathieu Othacehe July 25, 2019, 1:33 p.m. UTC | #2
> Does this still do the right thing in a native context?

My understanding is that in native context CMAKE_PREFIX_PATH will still
have the same value and it will be augmented with inputs in a
cross-build context.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7186cf98df..3969d309af 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -147,7 +147,7 @@ 
        ("ncurses" ,ncurses) ; required for ccmake
        ("rhash" ,rhash)
        ("zlib" ,zlib)))
-    (native-search-paths
+    (search-paths
      (list (search-path-specification
             (variable "CMAKE_PREFIX_PATH")
             (files '("")))))