diff mbox series

[bug#36477,24/31] gnu: xmlto: Fix cross-compilation.

Message ID 20190708095913.3460-25-m.othacehe@gmail.com
State Accepted
Headers show
Series Fix cross-compilation issues | expand

Commit Message

Mathieu Othacehe July 8, 2019, 9:59 a.m. UTC
* gnu/packages/xml.scm (xmlto)[inputs]: Move util-linux from here ...
[native-inputs]: ... to here.
---
 gnu/packages/xml.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Marius Bakke July 8, 2019, 6:18 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/xml.scm (xmlto)[inputs]: Move util-linux from here ...
> [native-inputs]: ... to here.

[...]

> diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
> index 5fefa2c1dc..5239070b1c 100644
> --- a/gnu/packages/xml.scm
> +++ b/gnu/packages/xml.scm
> @@ -915,9 +915,10 @@ code for classes that correspond to data structures defined by XMLSchema.")
>                                                (assoc-ref %build-inputs
>                                                           "util-linux")
>                                                "/bin/getopt"))))
> +    (native-inputs
> +     `(("util-linux" ,util-linux)))               ; for 'getopt'

The comments above this hunk suggest that util-linux must be a regular
input, since xmlto apparently needs getopt at run time.

So I suppose we need util-linux both as a native and regular input?
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5fefa2c1dc..5239070b1c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -915,9 +915,10 @@  code for classes that correspond to data structures defined by XMLSchema.")
                                               (assoc-ref %build-inputs
                                                          "util-linux")
                                               "/bin/getopt"))))
+    (native-inputs
+     `(("util-linux" ,util-linux)))               ; for 'getopt'
     (inputs
-     `(("util-linux" ,util-linux)                 ; for 'getopt'
-       ("libxml2" ,libxml2)                       ; for 'xmllint'
+     `(("libxml2" ,libxml2)                       ; for 'xmllint'
        ("libxslt" ,libxslt)))                     ; for 'xsltproc'
     (home-page "http://cyberelk.net/tim/software/xmlto/")
     (synopsis "Front-end to an XSL toolchain")