diff mbox series

[bug#35979,47/47] gnu: Add python-takethetime.

Message ID 20190529003724.3464-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Hamzeh Nasajpour May 29, 2019, 12:37 a.m. UTC
* gnu/packages/python-xyz.scm (python-takethetime): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2ebc79283..2ca5dbae4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15574,3 +15574,22 @@  by Igor Pavlov.")
 	With JSON we can make our logs more readable by machines and we can stop writing custom parsers for syslog type records.")
     (license license:expat)))
 
+(define-public python-takethetime
+  (package
+    (name "python-takethetime")
+    (version "0.3.1")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "TakeTheTime" version))
+      (sha256 (base32 "1y9gzqb9l1f2smx8783ccjzjvby5mphshgrfks7s75mml59h9qyv"))))
+    (build-system python-build-system)
+    (arguments
+      `(
+        #:tests? #f
+        ))
+    (inputs
+     `(("python-typing" ,python-typing)))
+    (home-page "https://github.com/ErikBjare/TakeTheTime")
+    (synopsis "Take The Time, a time-taking library for Python")
+    (description "Take The Time, a time-taking library for Python.")
+    (license license:expat)))