diff mbox series

[bug#35977,45/47] gnu: Add python-strict-rfc3339.

Message ID 20190529003621.3314-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Hamzeh Nasajpour May 29, 2019, 12:36 a.m. UTC
* gnu/packages/time.scm (python-strict-rfc3339): New variable
---
 gnu/packages/time.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Brett Gilio Dec. 10, 2019, 6:47 a.m. UTC | #1
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

> * gnu/packages/time.scm (python-strict-rfc3339): New variable
> ---
>  gnu/packages/time.scm | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)
>
> diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
> index 1363843b31..9e23ffae14 100644
> --- a/gnu/packages/time.scm
> +++ b/gnu/packages/time.scm
> @@ -440,3 +440,21 @@ datetime type.")
>  modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
>  calls.")
>      (license gpl2)))
> +
> +(define-public python-strict-rfc3339
> +  (package
> +    (name "python-strict-rfc3339")
> +    (version "0.7")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "strict-rfc3339" version))
> +      (sha256 (base32 "0xqjbsn0g1h88rayh5yrpdagq60zfwrfs3yvk6rmgby3vyz1gbaw"))))
> +    (build-system python-build-system)
> +    (arguments
> +      `(
> +        #:tests? #f
> +        ))
> +    (home-page "https://github.com/danielrichman/strict-rfc3339")
> +    (synopsis "Strict, simple, lightweight RFC3339 functions.")
> +    (description "Convert unix timestamps to and from RFC3339.")
> +    (license license:gpl3+)))

Hi,

Again, we are needing some revisions before this package is ready to be
merged. Spare my brevity, but here is a list.

1. The commit message does not follow our style guide.
2. The indentation for the hash is incorrect. See surrounding packages
for an idea of how to do this.
3. Parens should not go on lines by themselves.
4. Disabled tests should either be disabled with reason, but only if
they fail for reasons we can not control.
5. Synopsis/Description does not follow our style guide.

As before, if you need help please do let me know :).
Jelle Licht June 20, 2023, 9:22 p.m. UTC | #2
This package can be found in guix master. Closing.
- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 1363843b31..9e23ffae14 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -440,3 +440,21 @@  datetime type.")
 modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
 calls.")
     (license gpl2)))
+
+(define-public python-strict-rfc3339
+  (package
+    (name "python-strict-rfc3339")
+    (version "0.7")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "strict-rfc3339" version))
+      (sha256 (base32 "0xqjbsn0g1h88rayh5yrpdagq60zfwrfs3yvk6rmgby3vyz1gbaw"))))
+    (build-system python-build-system)
+    (arguments
+      `(
+        #:tests? #f
+        ))
+    (home-page "https://github.com/danielrichman/strict-rfc3339")
+    (synopsis "Strict, simple, lightweight RFC3339 functions.")
+    (description "Convert unix timestamps to and from RFC3339.")
+    (license license:gpl3+)))