diff mbox series

[bug#35978,46/47] gnu: Add python-json-logger.

Message ID 20190529003636.3364-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Hamzeh Nasajpour May 29, 2019, 12:36 a.m. UTC
* gnu/packages/python-xyz.scm (python-json-logger): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e47e5bbcd2..b2ebc79283 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15555,3 +15555,22 @@  by Igor Pavlov.")
      "persist-queue implements a file-based queue and a serial of sqlite3-based queues")
     (license license:bsd-2)))
 
+(define-public python-json-logger
+  (package
+    (name "python-json-logger")
+    (version "0.1.11")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "python-json-logger" version))
+      (sha256 (base32 "10g2ya6nsvn5vxzvq2wb8q4d43i3d7756i5rxyjna6d0y9i138xp"))))
+    (build-system python-build-system)
+    (arguments
+      `(
+        #:tests? #f
+        ))
+    (home-page "https://github.com/madzak/python-json-logger")
+    (synopsis "A python library adding a json log formatter.")
+    (description "This library is provided to allow standard python logging to output log data as json objects. 
+	With JSON we can make our logs more readable by machines and we can stop writing custom parsers for syslog type records.")
+    (license license:expat)))
+