diff mbox series

[bug#35974,42/47] gnu: Add python-typed-ast.

Message ID 20190529003459.3108-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Hamzeh Nasajpour May 29, 2019, 12:34 a.m. UTC
* gnu/packages/python-xyz.scm (python-typed-ast): New variable
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Brett Gilio Dec. 10, 2019, 6:07 a.m. UTC | #1
Closing.

This package was added with commit was applied with commit
dae2eb1c127c636226ba11d05ec638f113a3c831 on 2019-06-26.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c06833cec..93783d17ee 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15474,3 +15474,25 @@  by Igor Pavlov.")
     (description
      "A module for cross-platform control of the mouse and keyboard in python that is simple to use.")
     (license license:lgpl3)))
+
+(define-public python-typed-ast
+  (package
+  (name "python-typed-ast")
+    (version "1.3.5")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "typed-ast" version))
+      (sha256 (base32 "1m7pr6qpana3cvqwiw7mlvrgvmw27ch5mx1592572xhlki8g85ak"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://github.com/python/typed_ast")
+    (synopsis "A fork of Python 2 and 3 ast modules with type comment support")
+    (description
+     "typed_ast is a Python 3 package that provides a Python 2.7 and Python 3 parser similar to the standard ast library.
+	 Unlike ast, the parsers in typed_ast include PEP 484 type comments and are independent of the version of Python under which they are run.
+	 The typed_ast parsers produce the standard Python AST (plus type comments), and are both fast and correct,
+	 as they are based on the CPython 2.7 and 3.6 parsers.")
+    (license license:expat)))
+
+