diff mbox series

[bug#35975,43/47] gnu: Add python-mypy.

Message ID 20190529003550.3213-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Hamzeh Nasajpour May 29, 2019, 12:35 a.m. UTC
* gnu/packages/python-xyz.scm (python-mypy): New variable
* gnu/packages/python-xyz.scm (python-mypy_extensions): New variable
---
 gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Brett Gilio Dec. 10, 2019, 6:42 a.m. UTC | #1
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

> * gnu/packages/python-xyz.scm (python-mypy): New variable
> * gnu/packages/python-xyz.scm (python-mypy_extensions): New variable
> ---
>  gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 93783d17ee..298a59f59f 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15495,4 +15495,45 @@ by Igor Pavlov.")
>  	 as they are based on the CPython 2.7 and 3.6 parsers.")
>      (license license:expat)))
>  
> +(define-public python-mypy_extensions
> +  (package
> +  (name "python-mypy_extensions")
> +    (version "0.4.1")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "mypy_extensions" version))
> +      (sha256 (base32 "04h8brrbbx151dfa2cvvlnxgmb5wa00mhd2z7nd20s8kyibfkq1p"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (home-page "http://www.mypy-lang.org/")
> +    (synopsis "Experimental type system extensions for programs checked with the mypy typechecker.")
> +    (description
> +     "The “mypy_extensions” module defines experimental extensions to the standard “typing” module that are supported by the mypy typechecker..")
> +    (license license:expat)))
> +
> +(define-public python-mypy
> +  (package
> +  (name "python-mypy")
> +    (version "0.701")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "mypy" version))
> +      (sha256 (base32 "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +	(inputs `(
> +		("python-typed-ast" , python-typed-ast)
> +		("python-mypy_extensions" , python-mypy_extensions)
> +		("python-typed-ast" , python-typed-ast)
> +		))
> +    (home-page "http://www.mypy-lang.org/")
> +    (synopsis "Optional static typing for Python (mypyc-compiled version)")
> +    (description
> +     "Add type annotations to your Python programs, and use mypy to type check them.
> +	 Mypy is essentially a Python linter on steroids, and it can catch many programming errors by analyzing your program,
> +	 without actually having to run it. Mypy has a powerful type system with features such as type inference,
> +	 gradual typing, generics and union types.")
> +    (license license:expat)))

Hi,

This package requires a few revisions before it can be merged to master.

If you could separate the packages out either as separate patches in a
series or by having the extensions package as a native input defined
inline of the `python-mypy' package that would be terrific!

Additionally, there are several issues with indentation. Generally we do
not like open and close parenthesis along on lines by
themselves. Additionally there are some issues with your
description. Make sure to run `guix lint` to catch some of these issues.

Lastly, this package has a new version upstream.

If you need help let me know! Thanks!
Simon Tournier April 7, 2022, 1:04 p.m. UTC | #2
Hi,

Thanks for your submission.  Guix currently provides MyPy added by
4fae4f9aab806451535db032b43cba558668cf64 therefore I am closing.


On Wed, 29 May 2019 at 05:05, "h.nasajpour" <h.nasajpour@pantherx.org> wrote:

> +(define-public python-mypy
> +  (package
> +  (name "python-mypy")
> +    (version "0.701")

--8<---------------cut here---------------start------------->8---
$ guix show python-mypy | recsel -p name,version
name: python-mypy
version: 0.931
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93783d17ee..298a59f59f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15495,4 +15495,45 @@  by Igor Pavlov.")
 	 as they are based on the CPython 2.7 and 3.6 parsers.")
     (license license:expat)))
 
+(define-public python-mypy_extensions
+  (package
+  (name "python-mypy_extensions")
+    (version "0.4.1")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "mypy_extensions" version))
+      (sha256 (base32 "04h8brrbbx151dfa2cvvlnxgmb5wa00mhd2z7nd20s8kyibfkq1p"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (home-page "http://www.mypy-lang.org/")
+    (synopsis "Experimental type system extensions for programs checked with the mypy typechecker.")
+    (description
+     "The “mypy_extensions” module defines experimental extensions to the standard “typing” module that are supported by the mypy typechecker..")
+    (license license:expat)))
+
+(define-public python-mypy
+  (package
+  (name "python-mypy")
+    (version "0.701")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "mypy" version))
+      (sha256 (base32 "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+	(inputs `(
+		("python-typed-ast" , python-typed-ast)
+		("python-mypy_extensions" , python-mypy_extensions)
+		("python-typed-ast" , python-typed-ast)
+		))
+    (home-page "http://www.mypy-lang.org/")
+    (synopsis "Optional static typing for Python (mypyc-compiled version)")
+    (description
+     "Add type annotations to your Python programs, and use mypy to type check them.
+	 Mypy is essentially a Python linter on steroids, and it can catch many programming errors by analyzing your program,
+	 without actually having to run it. Mypy has a powerful type system with features such as type inference,
+	 gradual typing, generics and union types.")
+    (license license:expat)))