diff mbox series

[bug#35950,2/3] gnu: python-flask-restful: Update to 0.12.1.

Message ID 20190528105722.3697-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Hamzeh Nasajpour May 28, 2019, 10:57 a.m. UTC
* gnu/packages/python-web.scm (python-flask-restful): Update to 0.12.1.
---
 gnu/packages/python-web.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Brett Gilio Dec. 10, 2019, 6:29 a.m. UTC | #1
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

> * gnu/packages/python-web.scm (python-flask-restful): Update to 0.12.1.
> ---
>  gnu/packages/python-web.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index f962ae381f..79f4ec3565 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -2098,14 +2098,14 @@ pretty printer and a tree visitor.")
>  (define-public python-flask-restful
>    (package
>      (name "python-flask-restful")
> -    (version "0.3.7")
> +    (version "0.12.1")
>      (source
>        (origin
>          (method url-fetch)
>          (uri (pypi-uri "Flask-RESTful" version))
>          (sha256
>           (base32
> -          "1a9cbwkr6krryyzq4sd3f415nkkc6dyfls5i3pgyibs94g0hw97q"))))
> +          "0qmb5sfijl4h9jw43zx4qm8sff7l0dhbig4a0wyc3pwi3mz6kb9z"))))
>      (build-system python-build-system)
>      (propagated-inputs
>        `(("python-aniso8601" ,python-aniso8601)

Failing builds aside, I am not sure about the versioning. Pypi shows me
that Flask-RESTful is still tracking 0.3.7. If this is wrong we can
reopen this bug report, but until then I am closing it.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f962ae381f..79f4ec3565 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2098,14 +2098,14 @@  pretty printer and a tree visitor.")
 (define-public python-flask-restful
   (package
     (name "python-flask-restful")
-    (version "0.3.7")
+    (version "0.12.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "Flask-RESTful" version))
         (sha256
          (base32
-          "1a9cbwkr6krryyzq4sd3f415nkkc6dyfls5i3pgyibs94g0hw97q"))))
+          "0qmb5sfijl4h9jw43zx4qm8sff7l0dhbig4a0wyc3pwi3mz6kb9z"))))
     (build-system python-build-system)
     (propagated-inputs
       `(("python-aniso8601" ,python-aniso8601)