diff mbox series

[bug#35949,3/3] gnu: Add python-flask-cors.

Message ID 20190528105743.3749-1-h.nasajpour@pantherx.org
State Accepted
Headers show
Series [bug#35948,1/3] gnu: python-flask: Update to 1.0.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Hamzeh Nasajpour May 28, 2019, 10:57 a.m. UTC
* gnu/packages/python-web.scm (python-flask-cors): New variable.
---
 gnu/packages/python-web.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Danny Milosavljevic May 28, 2019, 7:09 p.m. UTC | #1
Hi,

On Tue, 28 May 2019 15:27:43 +0430
"h.nasajpour" <h.nasajpour@pantherx.org> wrote:

> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "Flask-Cors" version))
> +      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))

Strange indentation. 

> +    (arguments
> +     `(#:tests? #f))

Please add a comment with the reason.
 
> +    (propagated-inputs
> +      `(("python-six" ,python-six)
> +        ("python-flask" ,python-flask)))
> +    (home-page "https://github.com/corydolphin/flask-cors")
> +    (synopsis "A Flask extension adding a decorator for CORS support")
> +    (description
> +     "A Flask extension adding a decorator for CORS support")

Please add text to the description that describes what CORS is.
Also, the description should be full sentences.
Hamzeh Nasajpour May 29, 2019, 12:58 a.m. UTC | #2
+(define-public python-flask-cors
+  (package
+  (name "python-flask-cors")
+    (version "3.0.7")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-Cors" version))
+      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (propagated-inputs
+      `(("python-six" ,python-six)
+        ("python-flask" ,python-flask)))
+    (home-page "https://github.com/corydolphin/flask-cors")
+    (synopsis "A Flask extension adding a decorator for CORS support")
+    (description
+     "This package has a simple philosophy, when you want to enable CORS, you wish to enable it for all use cases on a domain. This means no mucking around with different allowed headers, methods, etc. By default, submission of cookies across domains is disabled due to the security implications")
+    (license license:expat)))
+

On Tue, May 28, 2019, at 11:39 PM, Danny Milosavljevic wrote:
> Hi,
> 
> On Tue, 28 May 2019 15:27:43 +0430
> "h.nasajpour" <h.nasajpour@pantherx.org> wrote:
> 
> > +    (source (origin
> > +      (method url-fetch)
> > +      (uri (pypi-uri "Flask-Cors" version))
> > +      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> 
> Strange indentation. 
> 
> > +    (arguments
> > +     `(#:tests? #f))
> 
> Please add a comment with the reason.
>  
> > +    (propagated-inputs
> > +      `(("python-six" ,python-six)
> > +        ("python-flask" ,python-flask)))
> > +    (home-page "https://github.com/corydolphin/flask-cors")
> > +    (synopsis "A Flask extension adding a decorator for CORS support")
> > +    (description
> > +     "A Flask extension adding a decorator for CORS support")
> 
> Please add text to the description that describes what CORS is.
> Also, the description should be full sentences.
>
Hamzeh Nasajpour July 29, 2019, 6:45 a.m. UTC | #3
Hi,

What's the status of this patch?

Regards,

On Wed, May 29, 2019, at 5:28 AM, Hamzeh Nasajpour wrote:
> +(define-public python-flask-cors
> +  (package
> +  (name "python-flask-cors")
> +    (version "3.0.7")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "Flask-Cors" version))
> +      (sha256 (base32 
> "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (propagated-inputs
> +      `(("python-six" ,python-six)
> +        ("python-flask" ,python-flask)))
> +    (home-page "https://github.com/corydolphin/flask-cors")
> +    (synopsis "A Flask extension adding a decorator for CORS support")
> +    (description
> +     "This package has a simple philosophy, when you want to enable 
> CORS, you wish to enable it for all use cases on a domain. This means 
> no mucking around with different allowed headers, methods, etc. By 
> default, submission of cookies across domains is disabled due to the 
> security implications")
> +    (license license:expat)))
> +
> 
> On Tue, May 28, 2019, at 11:39 PM, Danny Milosavljevic wrote:
> > Hi,
> > 
> > On Tue, 28 May 2019 15:27:43 +0430
> > "h.nasajpour" <h.nasajpour@pantherx.org> wrote:
> > 
> > > +    (source (origin
> > > +      (method url-fetch)
> > > +      (uri (pypi-uri "Flask-Cors" version))
> > > +      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> > 
> > Strange indentation. 
> > 
> > > +    (arguments
> > > +     `(#:tests? #f))
> > 
> > Please add a comment with the reason.
> >  
> > > +    (propagated-inputs
> > > +      `(("python-six" ,python-six)
> > > +        ("python-flask" ,python-flask)))
> > > +    (home-page "https://github.com/corydolphin/flask-cors")
> > > +    (synopsis "A Flask extension adding a decorator for CORS support")
> > > +    (description
> > > +     "A Flask extension adding a decorator for CORS support")
> > 
> > Please add text to the description that describes what CORS is.
> > Also, the description should be full sentences.
> >
Brett Gilio Dec. 10, 2019, 6:34 a.m. UTC | #4
"Hamzeh Nasajpour" <h.nasajpour@pantherx.org> writes:

> +(define-public python-flask-cors
> +  (package
> +  (name "python-flask-cors")
> +    (version "3.0.7")
> +    (source (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "Flask-Cors" version))
> +      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (propagated-inputs
> +      `(("python-six" ,python-six)
> +        ("python-flask" ,python-flask)))
> +    (home-page "https://github.com/corydolphin/flask-cors")
> +    (synopsis "A Flask extension adding a decorator for CORS support")
> +    (description
> + "This package has a simple philosophy, when you want to enable CORS,
> you wish to enable it for all use cases on a domain. This means no
> mucking around with different allowed headers, methods, etc. By
> default, submission of cookies across domains is disabled due to the
> security implications")
> +    (license license:expat)))
> +

Hi Hamzeh,

This patch still needs some revision. Could you please send a properly
formatted [PATCH v2 x/1] with an explanation as to why the tests are
disabled, corrected indentation, and a description that matches our
style guide.

https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

Thanks! If you need help, let me know.
Simon Tournier April 7, 2022, 1:07 p.m. UTC | #5
Hi,

Thank you for the submission.  Currently, the version is
python-flask-cors is 0.3.10.  Therefore, closing!


On Tue, 28 May 2019 at 15:27, "h.nasajpour" <h.nasajpour@pantherx.org> wrote:

> +(define-public python-flask-cors
> +  (package
> +  (name "python-flask-cors")
> +    (version "3.0.7")

--8<---------------cut here---------------start------------->8---
$ guix show python-flask-cors | recsel -p name,version
name: python-flask-cors
version: 3.0.10
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 79f4ec3565..ab11119f07 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2095,6 +2095,26 @@  SlimIt also provides a library that includes a JavaScript parser, lexer,
 pretty printer and a tree visitor.")
     (license license:expat)))
 
+(define-public python-flask-cors
+  (package
+  (name "python-flask-cors")
+    (version "3.0.7")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-Cors" version))
+      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (propagated-inputs
+      `(("python-six" ,python-six)
+        ("python-flask" ,python-flask)))
+    (home-page "https://github.com/corydolphin/flask-cors")
+    (synopsis "A Flask extension adding a decorator for CORS support")
+    (description
+     "A Flask extension adding a decorator for CORS support")
+    (license license:expat)))
+
 (define-public python-flask-restful
   (package
     (name "python-flask-restful")