diff mbox series

[bug#36797,08/11] gnu: Add r-flowpeaks.

Message ID 20190724182204.6818-9-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r packages to process flow cytometry data | expand

Commit Message

Simon Tournier July 24, 2019, 6:22 p.m. UTC
* gnu/packages/bioconductor.scm (r-flowpeaks): New variable.
---
 gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ricardo Wurmus July 24, 2019, 8:51 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/bioconductor.scm (r-flowpeaks): New variable.
[…]
> +    (license license:artistic2.0)))     ;TODO: artistic1.0 does not exist

Unfortunately, version 1.0 of the Artistic License is too unclear to be
considered a free license.  I have excluded this package from the
set of patches that I’ll apply to the master branch.
Simon Tournier Feb. 21, 2020, 5:07 p.m. UTC | #2
Dear,

All the patches are merged now; except r-flowpeaks. Because this
package use Artistic1.0 which is not enough clear to be considered
"free" [1,2] (GNU's point of view [3]) and upstream are not
responsive, let clean the bug tracker. :-)

[1] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36797#16
[2] https://lists.gnu.org/archive/html/guix-devel/2019-12/msg00286.html
[3] https://www.gnu.org/licenses/license-list.en.html#ArtisticLicense

All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0f023665c2..ab4d9f4075 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4907,3 +4907,26 @@  and to both short and long sequence reads.")
     (description
       "Identifies cell populations in Flow Cytometry data using non-parametric clustering and segmented-regression-based change point detection.  Note: R 2.11.0 or newer is required.")
     (license license:artistic2.0)))
+
+(define-public r-flowpeaks
+  (package
+    (name "r-flowpeaks")
+    (version "1.30.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "flowPeaks" version))
+        (sha256
+          (base32
+            "1ncz7n6n39svi444yy29ip53398392s3m6z0h2a77rhcnzg456wy"))))
+    (properties `((upstream-name . "flowPeaks")))
+    (build-system r-build-system)
+    (inputs `(("gsl" ,gsl)))
+    (home-page
+      "https://bioconductor.org/packages/flowPeaks")
+    (synopsis
+      "An R package for flow data clustering")
+    (description
+      "This package provides a fast and automatic clustering to classify the cells into subpopulations based on finding the peaks from the overall density function generated by K-means.")
+    (license license:artistic2.0)))     ;TODO: artistic1.0 does not exist
+