diff mbox series

[bug#36798,09/11] gnu: Add r-flowsom.

Message ID 20190724182204.6818-10-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r packages to process flow cytometry data | expand

Commit Message

Simon Tournier July 24, 2019, 6:22 p.m. UTC
* gnu/packages/bioconductor.scm (r-flowsom): New variable.
---
 gnu/packages/bioconductor.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ab4d9f4075..dd6570ed17 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4930,3 +4930,32 @@  and to both short and long sequence reads.")
       "This package provides a fast and automatic clustering to classify the cells into subpopulations based on finding the peaks from the overall density function generated by K-means.")
     (license license:artistic2.0)))     ;TODO: artistic1.0 does not exist
 
+(define-public r-flowsom
+  (package
+    (name "r-flowsom")
+    (version "1.16.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "FlowSOM" version))
+        (sha256
+          (base32
+            "03wl3xk7g7vajc4kkrqa0gsbjfxlqr918qi849h5nir31963398l"))))
+    (properties `((upstream-name . "FlowSOM")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-biocgenerics" ,r-biocgenerics)
+        ("r-consensusclusterplus"
+         ,r-consensusclusterplus)
+        ("r-flowcore" ,r-flowcore)
+        ("r-flowutils" ,r-flowutils)
+        ("r-igraph" ,r-igraph)
+        ("r-tsne" ,r-tsne)
+        ("r-xml" ,r-xml)))
+    (home-page "http://www.r-project.org")
+    (synopsis
+      "Using self-organizing maps for visualization and interpretation of cytometry data")
+    (description
+      "FlowSOM offers visualization options for cytometry data, by using Self-Organizing Map clustering and Minimal Spanning Trees.")
+    (license license:gpl2+)))
+