diff mbox series

[bug#36793,04/11] gnu: Add r-flowcore.

Message ID 20190724182204.6818-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r packages to process flow cytometry data | expand

Commit Message

Simon Tournier July 24, 2019, 6:21 p.m. UTC
* gnu/packages/bioconductor.scm (r-flowcore): New variable.
---
 gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 18b5711496..3a38042537 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4799,3 +4799,33 @@  read mapping, read counting, SNP calling, structural variant detection and
 gene fusion discovery.  It can be applied to all major sequencing techologies
 and to both short and long sequence reads.")
     (license license:gpl3)))
+
+(define-public r-flowcore
+  (package
+    (name "r-flowcore")
+    (version "1.50.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "flowCore" version))
+        (sha256
+          (base32
+            "0pvcyzycsmgc8iw60q9xnhllfan6ihwpz3gvk8h1n9jmhpxzylan"))))
+    (properties `((upstream-name . "flowCore")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-bh" ,r-bh)
+        ("r-biobase" ,r-biobase)
+        ("r-biocgenerics" ,r-biocgenerics)
+        ("r-corpcor" ,r-corpcor)
+        ("r-graph" ,r-graph)
+        ("r-mass" ,r-mass)
+        ("r-matrixstats" ,r-matrixstats)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rrcov" ,r-rrcov)))
+    (home-page
+      "https://bioconductor.org/packages/flowCore")
+    (synopsis "Basic structures for flow cytometry data")
+    (description
+      "Provides S4 data structures and basic functions to deal with flow cytometry data.")
+    (license license:artistic2.0)))