diff mbox series

[bug#36790,01/11] gnu: Add r-umap.

Message ID 20190724182204.6818-2-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r packages to process flow cytometry data | expand

Commit Message

Simon Tournier July 24, 2019, 6:21 p.m. UTC
* gnu/packages/cran.scm (r-umap): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Simon Tournier July 24, 2019, 7:17 p.m. UTC | #1
merge 36789 36790
thanks
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3f0d819df7..768a7d09c5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14530,3 +14530,30 @@  including regression, classification and ranking.  The package is made to be
 extensible, so that users are also allowed to define their own objectives
 easily.")
     (license license:asl2.0)))
+
+(define-public r-umap
+  (package
+    (name "r-umap")
+    (version "0.2.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "umap" version))
+        (sha256
+          (base32
+            "1s82w9gy1387h7cprjfbhp49l89zbmn3gc9s0wzqb1s73nza9n31"))))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-rcpp" ,r-rcpp)
+        ("r-reticulate" ,r-reticulate)
+        ("r-rspectra" ,r-rspectra)))
+    (home-page "https://github.com/tkonopka/umap")
+    (synopsis
+      "Uniform Manifold Approximation and Projection")
+    (description
+      "Uniform manifold approximation and projection is a technique for
+dimension reduction.  The algorithm was described by McInnes and Healy (2018)
+in <arXiv:1802.03426>.  This package provides an interface to the UMAP
+algorithm in R, including a translation of the original algorithm into R with
+minimal dependencies.")
+    (license license:expat)))