diff mbox series

[bug#36794,05/11] gnu: Add r-flowutils.

Message ID 20190724182204.6818-6-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r packages to process flow cytometry data | expand

Commit Message

Simon Tournier July 24, 2019, 6:21 p.m. UTC
* gnu/packages/bioconductor.scm (r-flowutils): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3a38042537..d79ff729fc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4800,6 +4800,33 @@  gene fusion discovery.  It can be applied to all major sequencing techologies
 and to both short and long sequence reads.")
     (license license:gpl3)))
 
+(define-public r-flowutils
+  (package
+    (name "r-flowutils")
+    (version "1.48.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "flowUtils" version))
+        (sha256
+          (base32
+            "1r7b0rszdzjq7jphh65p5m4x5ps0zbbagxl26gn2mapbjdyb47rm"))))
+    (properties `((upstream-name . "flowUtils")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-biobase" ,r-biobase)
+        ("r-corpcor" ,r-corpcor)
+        ("r-flowcore" ,r-flowcore)
+        ("r-graph" ,r-graph)
+        ("r-runit" ,r-runit)
+        ("r-xml" ,r-xml)))
+    (home-page
+      "https://github.com/jspidlen/flowUtils")
+    (synopsis "Utilities for flow cytometry")
+    (description
+      "Provides utilities for flow cytometry data.")
+    (license license:artistic2.0)))
+
 (define-public r-flowcore
   (package
     (name "r-flowcore")