diff mbox series

[bug#70031,core-updates,11/19] gnu: vigra: Move test target to check phase.

Message ID fe1d72f5131b889c4c91b0f2ef4b134c879ab62f.1711549374.git.code@greghogan.com
State New
Headers show
Series Use CMake in build-system/cmake. | expand

Commit Message

Greg Hogan March 27, 2024, 2:52 p.m. UTC
* gnu/packages/image.scm (vigra)[arguments]: Replace 'check phase to
replace the old cmake-build-system test target.

Change-Id: I6465caaff8c249373537652d001b22a4d9eafe09
---
 gnu/packages/image.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 6accf68ef09..45ded6af04b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1370,8 +1370,7 @@  (define-public vigra
         ("python-nose" ,python-nose)
         ("sphinx" ,python-sphinx)))
      (arguments
-      `(#:test-target "check"
-        #:phases
+      `(#:phases
         (modify-phases %standard-phases
           (add-after 'unpack 'disable-broken-tests
             (lambda _
@@ -1382,7 +1381,11 @@  (define-public vigra
               ;; <https://github.com/ukoethe/vigra/issues/436>.
               (substitute* "vigranumpy/test/CMakeLists.txt"
                 (("test1\\.py") ""))
-              #t)))
+              #t))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "make" "check")))))
         #:configure-flags
           (list "-Wno-dev" ; suppress developer mode with lots of warnings
                 (string-append "-DVIGRANUMPY_INSTALL_DIR="