diff mbox series

[bug#70031,core-updates,10/19] gnu: inkscape: Move test target to check phase.

Message ID f7fb1c465b5f80e4a47913b34f4d761da763615d.1711549374.git.code@greghogan.com
State New
Headers show
Series Use CMake in build-system/cmake. | expand

Commit Message

Greg Hogan March 27, 2024, 2:52 p.m. UTC
* gnu/packages/inkscape.scm (inkscape)[arguments]: Replace 'check phase to
replace the old cmake-build-system test target.

Change-Id: I2d7046baaaa5bfcd6909d0d9dc3e6e6c4eb3e1e3
---
 gnu/packages/inkscape.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a09..9ce9f81cfda 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -156,8 +156,7 @@  (define-public inkscape/stable
               ((".*find_package\\(DoubleConversion.*") ""))))))
      (build-system cmake-build-system)
      (arguments
-      `(#:test-target "check"         ;otherwise some test binaries are missing
-        #:imported-modules (,@%cmake-build-system-modules
+      `(#:imported-modules (,@%cmake-build-system-modules
                             (guix build glib-or-gtk-build-system))
         #:modules ((guix build cmake-build-system)
                    ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
@@ -220,7 +219,10 @@  (define-public inkscape/stable
           ;; as the "share/inkscape/ui/units.xml" file.
           (delete 'check)
           (add-after 'install 'check
-            (assoc-ref %standard-phases 'check))
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                ;; Test artifacts and actions are built with the 'test' target.
+                (invoke "make" "check"))))
           (add-after 'install 'glib-or-gtk-compile-schemas
             (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
           (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap