diff mbox series

[bug#70031,core-updates,09/19] gnu: igraph: Move test target to check phase.

Message ID 1be9ed6dba126f3705d7c7c25364c58586994e13.1711549374.git.code@greghogan.com
State New
Headers show
Series Use CMake in build-system/cmake. | expand

Commit Message

Greg Hogan March 27, 2024, 2:52 p.m. UTC
* gnu/packages/graph.scm (igraph)[arguments]: Replace 'check phase to
replace the old cmake-build-system test target.

Change-Id: Idf5a8913e22f30b1aa02fdad12212bf690ddc0c4
---
 gnu/packages/graph.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index a3607689a3e..30dd1a59cfa 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -142,7 +142,6 @@  (define-public igraph
               ;; Use the same integer width as suitesparse-cxsparse, which
               ;; uses int64_t in SuiteSparse v6.0.0 and later.
               "-DIGRAPH_INTEGER_SIZE=64")
-      #:test-target "check"
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'version-file
@@ -174,6 +173,10 @@  (define-public igraph
           (add-after 'build 'build-doc
             (lambda _
               (invoke "cmake" "--build" "." "--target" "html")))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "make" "check"))))
           (add-after 'install 'install-doc
             (lambda _
               (copy-recursively