diff mbox series

[bug#50091,18/21] gnu: texlive-bin: Fix building on riscv64-linux.

Message ID fce3042c7a0acd26a32f548cc870a9c353e81457.1629193993.git.efraim@flashner.co.il
State New
Headers show
Series Add riscv64 support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 17, 2021, 10:19 a.m. UTC
* gnu/packages/tex.scm (texlive-bin)[arguments]: Adjust configure-flags
for riscv64-linux to skip luajit based binaries. Add phase to skip some
tests.
---
 gnu/packages/tex.scm | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

Comments

Efraim Flashner Aug. 17, 2021, 10:34 a.m. UTC | #1
On Tue, Aug 17, 2021 at 01:19:16PM +0300, Efraim Flashner wrote:
> * gnu/packages/tex.scm (texlive-bin)[arguments]: Adjust configure-flags
> for riscv64-linux to skip luajit based binaries. Add phase to skip some
> tests.
> ---
>  gnu/packages/tex.scm | 18 ++++++++++--------
>  1 file changed, 10 insertions(+), 8 deletions(-)
> 
> diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> index c00c2ae177..b96aadc357 100644
> --- a/gnu/packages/tex.scm
> +++ b/gnu/packages/tex.scm
> @@ -338,13 +338,14 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
>           "--with-system-teckit"
>           "--with-system-zlib"
>           "--with-system-zziplib"
> -         ;; LuaJIT is not ported to powerpc64le* yet.
> -         ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
> -                                                 (%current-system)))
> -               '("--disable-luajittex"
> -                 "--disable-luajithbtex"
> -                 "--disable-mfluajit")
> -               '()))
> +         ;; LuaJIT is not ported to some architectures yet.
> +         ,@(if (or (string-prefix? "powerpc64le" (or (%current-target-system)
> +                                                     (%current-system)))
> +                   (target-riscv?))

I don't think I pushed the patch yet to add target-ppc64le? as an option
yet, but I'll rewrite this one when I do.

> +             '("--disable-luajittex"
> +               "--disable-luajithbtex"
> +               "--disable-mfluajit")
> +             '()))
>  
>        ;; Disable tests on some architectures to cope with a failure of
>        ;; luajiterr.test.
> @@ -385,7 +386,8 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
>                 (("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck \\|\\| exit 1")
>                  "./omfonts -ofm2opl $srcdir/tests/check tests/xcheck || exit 77"))
>               #t))
> -         ,@(if (target-ppc32?)
> +         ,@(if (or (target-ppc32?)
> +                   (target-riscv?))
>               ;; Some mendex tests fail on some architectures.
>               `((add-after 'unpack 'skip-mendex-tests
>                   (lambda _
> -- 
> 2.32.0
>
Thiago Jung Bauermann Aug. 17, 2021, 3:15 p.m. UTC | #2
Hello Efraim,

Em terça-feira, 17 de agosto de 2021, às 07:34:11 -03, Efraim Flashner 
escreveu:
> On Tue, Aug 17, 2021 at 01:19:16PM +0300, Efraim Flashner wrote:
> > * gnu/packages/tex.scm (texlive-bin)[arguments]: Adjust configure-flags
> > for riscv64-linux to skip luajit based binaries. Add phase to skip some
> > tests.
> > ---
> > 
> >  gnu/packages/tex.scm | 18 ++++++++++--------
> >  1 file changed, 10 insertions(+), 8 deletions(-)
> > 
> > diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> > index c00c2ae177..b96aadc357 100644
> > --- a/gnu/packages/tex.scm
> > +++ b/gnu/packages/tex.scm
> > @@ -338,13 +338,14 @@ files from LOCATIONS with expected checksum HASH.
> >  CODE is not currently in use.> 
> >           "--with-system-teckit"
> >           "--with-system-zlib"
> >           "--with-system-zziplib"
> > 
> > -         ;; LuaJIT is not ported to powerpc64le* yet.
> > -         ,@(if (string-prefix? "powerpc64le" (or
> > (%current-target-system) -                                            
> >     (%current-system))) -               '("--disable-luajittex"
> > -                 "--disable-luajithbtex"
> > -                 "--disable-mfluajit")
> > -               '()))
> > +         ;; LuaJIT is not ported to some architectures yet.
> > +         ,@(if (or (string-prefix? "powerpc64le" (or
> > (%current-target-system) +                                            
> >         (%current-system))) +                   (target-riscv?))
> 
> I don't think I pushed the patch yet to add target-ppc64le? as an option
> yet, but I'll rewrite this one when I do.

Nice, thanks!

You’ll also need a corresponding change in ‘texlive-texmf’, similar to the 
one added in https://issues.guix.gnu.org/50081 .
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c00c2ae177..b96aadc357 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -338,13 +338,14 @@  files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
          "--with-system-teckit"
          "--with-system-zlib"
          "--with-system-zziplib"
-         ;; LuaJIT is not ported to powerpc64le* yet.
-         ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
-                                                 (%current-system)))
-               '("--disable-luajittex"
-                 "--disable-luajithbtex"
-                 "--disable-mfluajit")
-               '()))
+         ;; LuaJIT is not ported to some architectures yet.
+         ,@(if (or (string-prefix? "powerpc64le" (or (%current-target-system)
+                                                     (%current-system)))
+                   (target-riscv?))
+             '("--disable-luajittex"
+               "--disable-luajithbtex"
+               "--disable-mfluajit")
+             '()))
 
       ;; Disable tests on some architectures to cope with a failure of
       ;; luajiterr.test.
@@ -385,7 +386,8 @@  files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
                (("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck \\|\\| exit 1")
                 "./omfonts -ofm2opl $srcdir/tests/check tests/xcheck || exit 77"))
              #t))
-         ,@(if (target-ppc32?)
+         ,@(if (or (target-ppc32?)
+                   (target-riscv?))
              ;; Some mendex tests fail on some architectures.
              `((add-after 'unpack 'skip-mendex-tests
                  (lambda _