diff mbox series

[bug#50091,17/21] gnu: openlibm: Remove riscv64-linux from supported systems.

Message ID 6a3bdea9a60b40fde06343607ee43f879aa7a228.1629193993.git.efraim@flashner.co.il
State New
Headers show
Series Add riscv64 support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 17, 2021, 10:19 a.m. UTC
* gnu/packages/maths.scm (openlibm)[supported-systems]: Remove
riscv64-linux.
---
 gnu/packages/maths.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index eb6e685278..06b9dfea59 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4250,7 +4250,8 @@  have a good libm for the Julia programming language that worked consistently
 across compilers and operating systems, and in 32-bit and 64-bit
 environments.")
     ;; Each architecture has its own make target, and there is none for mips.
-    (supported-systems (delete "mips64el-linux" %supported-systems))
+    (supported-systems (fold delete %supported-systems
+                             '("mips64el-linux" "riscv64-linux")))
     ;; See LICENSE.md for details.
     (license (list license:expat
                    license:isc