diff mbox series

[bug#50091,20/21] gnu: lz4: Build on riscv64-linux without valgrind.

Message ID 996a1fa4122eb34a09371956c0724728bd8a4145.1629193993.git.efraim@flashner.co.il
State New
Headers show
Series Add riscv64 support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 17, 2021, 10:19 a.m. UTC
* gnu/packages/compression.scm (lz4)[native-inputs]: Don't use valgrind
when building for riscv64-linux.
---
 gnu/packages/compression.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Aug. 17, 2021, 10:35 a.m. UTC | #1
On Tue, Aug 17, 2021 at 01:19:18PM +0300, Efraim Flashner wrote:
> * gnu/packages/compression.scm (lz4)[native-inputs]: Don't use valgrind
> when building for riscv64-linux.
> ---
>  gnu/packages/compression.scm | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
> index 93d517abd5..1803237e6e 100644
> --- a/gnu/packages/compression.scm
> +++ b/gnu/packages/compression.scm
> @@ -819,7 +819,9 @@ decompression of some loosely related file formats used by Microsoft.")
>      (native-inputs
>       `(;; For tests.
>         ("python" ,python)
> -       ("valgrind" ,valgrind)))
> +       ,@(if (target-riscv?)
> +           '()
> +           `(("valgrind" ,valgrind)))))
>      (arguments
>       `(;; Not designed for parallel testing.
>         ;; See https://github.com/lz4/lz4/issues/957#issuecomment-737419821
> -- 
> 2.32.0
> 

Valgrind added support for riscv64-linux after the last release, but the
patch isn't easy to backport. I've thought about adding a valgrind-next
and pulling from a recent commit but I'm not sure it's actually worth
it.
Thiago Jung Bauermann Aug. 17, 2021, 3:26 p.m. UTC | #2
Hello,

Em terça-feira, 17 de agosto de 2021, às 07:35:35 -03, Efraim Flashner 
escreveu:
> On Tue, Aug 17, 2021 at 01:19:18PM +0300, Efraim Flashner wrote:
> > * gnu/packages/compression.scm (lz4)[native-inputs]: Don't use valgrind
> > when building for riscv64-linux.
> > ---
> > 
> >  gnu/packages/compression.scm | 4 +++-
> >  1 file changed, 3 insertions(+), 1 deletion(-)
> > 
> > diff --git a/gnu/packages/compression.scm
> > b/gnu/packages/compression.scm
> > index 93d517abd5..1803237e6e 100644
> > --- a/gnu/packages/compression.scm
> > +++ b/gnu/packages/compression.scm
> > @@ -819,7 +819,9 @@ decompression of some loosely related file formats
> > used by Microsoft.")> 
> >      (native-inputs
> >      
> >       `(;; For tests.
> >       
> >         ("python" ,python)
> > 
> > -       ("valgrind" ,valgrind)))
> > +       ,@(if (target-riscv?)
> > +           '()
> > +           `(("valgrind" ,valgrind)))))
> > 
> >      (arguments
> >      
> >       `(;; Not designed for parallel testing.
> >       
> >         ;; See
> >         https://github.com/lz4/lz4/issues/957#issuecomment-737419821
> 
> Valgrind added support for riscv64-linux after the last release, but the
> patch isn't easy to backport. I've thought about adding a valgrind-next
> and pulling from a recent commit but I'm not sure it's actually worth
> it.

IMHO, either the commit message or the code would benefit from a note 
mentioning that the current version of Valgrind doesn’t support
riscv64-linux.
Efraim Flashner Aug. 18, 2021, 9:10 a.m. UTC | #3
On Tue, Aug 17, 2021 at 12:26:33PM -0300, Thiago Jung Bauermann wrote:
> Hello,
> 
> Em terça-feira, 17 de agosto de 2021, às 07:35:35 -03, Efraim Flashner 
> escreveu:
> > On Tue, Aug 17, 2021 at 01:19:18PM +0300, Efraim Flashner wrote:
> > > * gnu/packages/compression.scm (lz4)[native-inputs]: Don't use valgrind
> > > when building for riscv64-linux.
> > > ---
> > > 
> > >  gnu/packages/compression.scm | 4 +++-
> > >  1 file changed, 3 insertions(+), 1 deletion(-)
> > > 
> > > diff --git a/gnu/packages/compression.scm
> > > b/gnu/packages/compression.scm
> > > index 93d517abd5..1803237e6e 100644
> > > --- a/gnu/packages/compression.scm
> > > +++ b/gnu/packages/compression.scm
> > > @@ -819,7 +819,9 @@ decompression of some loosely related file formats
> > > used by Microsoft.")> 
> > >      (native-inputs
> > >      
> > >       `(;; For tests.
> > >       
> > >         ("python" ,python)
> > > 
> > > -       ("valgrind" ,valgrind)))
> > > +       ,@(if (target-riscv?)
> > > +           '()
> > > +           `(("valgrind" ,valgrind)))))
> > > 
> > >      (arguments
> > >      
> > >       `(;; Not designed for parallel testing.
> > >       
> > >         ;; See
> > >         https://github.com/lz4/lz4/issues/957#issuecomment-737419821
> > 
> > Valgrind added support for riscv64-linux after the last release, but the
> > patch isn't easy to backport. I've thought about adding a valgrind-next
> > and pulling from a recent commit but I'm not sure it's actually worth
> > it.
> 
> IMHO, either the commit message or the code would benefit from a note 
> mentioning that the current version of Valgrind doesn’t support
> riscv64-linux.
> 

Looks like I was mistaken, libunwind grew riscv64-linux support, not
valgrind.
diff mbox series

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 93d517abd5..1803237e6e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -819,7 +819,9 @@  decompression of some loosely related file formats used by Microsoft.")
     (native-inputs
      `(;; For tests.
        ("python" ,python)
-       ("valgrind" ,valgrind)))
+       ,@(if (target-riscv?)
+           '()
+           `(("valgrind" ,valgrind)))))
     (arguments
      `(;; Not designed for parallel testing.
        ;; See https://github.com/lz4/lz4/issues/957#issuecomment-737419821