diff mbox series

[bug#50091,11/21] gnu: libtool: Fix building on riscv64-linux.

Message ID 9aae8ef33d6bc84b2a0f3765ef56d00e0c4d3359.1629193993.git.efraim@flashner.co.il
State New
Headers show
Series Add riscv64 support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Aug. 17, 2021, 10:19 a.m. UTC
* gnu/packages/patches/libtool-skip-tests2.patch: Also skip pie tests
on riscv architectures.
---
 gnu/packages/patches/libtool-skip-tests2.patch | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Aug. 17, 2021, 10:32 a.m. UTC | #1
Since this touches the patch for libtool it would involve a rebuild of
everything depending on libtool. I can of course rewrite this so it adds
a phase only for riscv64-linux and then undo it in core-updates.

On Tue, Aug 17, 2021 at 01:19:09PM +0300, Efraim Flashner wrote:
> * gnu/packages/patches/libtool-skip-tests2.patch: Also skip pie tests
> on riscv architectures.
> ---
>  gnu/packages/patches/libtool-skip-tests2.patch | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/patches/libtool-skip-tests2.patch b/gnu/packages/patches/libtool-skip-tests2.patch
> index c9d61e3b41..b0a479325f 100644
> --- a/gnu/packages/patches/libtool-skip-tests2.patch
> +++ b/gnu/packages/patches/libtool-skip-tests2.patch
> @@ -1,4 +1,4 @@
> -Skip the nopic test on ARM and MIPS systems.
> +Skip the nopic test on ARM, MIPS and RISCV systems.
>  
>  --- libtool-2.4.6/tests/demo.at.orig	2015-01-16 13:52:04.000000000 -0500
>  +++ libtool-2.4.6/tests/demo.at	2015-02-16 10:48:51.435851966 -0500
> @@ -7,7 +7,7 @@ Skip the nopic test on ARM and MIPS systems.
>   
>   AT_CHECK([case $host in
>  -hppa*|x86_64*|s390*)
> -+hppa*|x86_64*|s390*|arm*|mips*)
> ++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
>     # These hosts cannot use non-PIC shared libs
>     exit 77 ;;
>   *-solaris*|*-sunos*)
> @@ -18,7 +18,7 @@ Skip the nopic test on ARM and MIPS systems.
>   { set +x
>   $as_echo "$at_srcdir/demo.at:535: case \$host in
>  -hppa*|x86_64*|s390*)
> -+hppa*|x86_64*|s390*|arm*|mips*)
> ++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
>     # These hosts cannot use non-PIC shared libs
>     exit 77 ;;
>   *-solaris*|*-sunos*)
> @@ -27,7 +27,7 @@ Skip the nopic test on ARM and MIPS systems.
>   at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
>   ( $at_check_trace; case $host in
>  -hppa*|x86_64*|s390*)
> -+hppa*|x86_64*|s390*|arm*|mips*)
> ++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
>     # These hosts cannot use non-PIC shared libs
>     exit 77 ;;
>   *-solaris*|*-sunos*)
> -- 
> 2.32.0
>
M Aug. 17, 2021, 10:49 a.m. UTC | #2
Efraim Flashner schreef op di 17-08-2021 om 13:19 [+0300]:
> * gnu/packages/patches/libtool-skip-tests2.patch: Also skip pie tests
> on riscv architectures.
> ---
>  gnu/packages/patches/libtool-skip-tests2.patch | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 

Does upstream know about the issue?
I would recommend including a link to the upstream bug report.
(in libtool-skip-tests2.patch or in a comment in the 'libtool'
package definition).

Greetings,
Maxime.
Efraim Flashner Aug. 17, 2021, 10:58 a.m. UTC | #3
On Tue, Aug 17, 2021 at 12:49:12PM +0200, Maxime Devos wrote:
> Efraim Flashner schreef op di 17-08-2021 om 13:19 [+0300]:
> > * gnu/packages/patches/libtool-skip-tests2.patch: Also skip pie tests
> > on riscv architectures.
> > ---
> >  gnu/packages/patches/libtool-skip-tests2.patch | 8 ++++----
> >  1 file changed, 4 insertions(+), 4 deletions(-)
> > 
> 
> Does upstream know about the issue?
> I would recommend including a link to the upstream bug report.
> (in libtool-skip-tests2.patch or in a comment in the 'libtool'
> package definition).
> 
> Greetings,
> Maxime.

I have to assume upstream knows about it, Debian has a similar patch
they've been using for years. I'll see what I can find about getting a
link for a bug report.
diff mbox series

Patch

diff --git a/gnu/packages/patches/libtool-skip-tests2.patch b/gnu/packages/patches/libtool-skip-tests2.patch
index c9d61e3b41..b0a479325f 100644
--- a/gnu/packages/patches/libtool-skip-tests2.patch
+++ b/gnu/packages/patches/libtool-skip-tests2.patch
@@ -1,4 +1,4 @@ 
-Skip the nopic test on ARM and MIPS systems.
+Skip the nopic test on ARM, MIPS and RISCV systems.
 
 --- libtool-2.4.6/tests/demo.at.orig	2015-01-16 13:52:04.000000000 -0500
 +++ libtool-2.4.6/tests/demo.at	2015-02-16 10:48:51.435851966 -0500
@@ -7,7 +7,7 @@  Skip the nopic test on ARM and MIPS systems.
  
  AT_CHECK([case $host in
 -hppa*|x86_64*|s390*)
-+hppa*|x86_64*|s390*|arm*|mips*)
++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
    # These hosts cannot use non-PIC shared libs
    exit 77 ;;
  *-solaris*|*-sunos*)
@@ -18,7 +18,7 @@  Skip the nopic test on ARM and MIPS systems.
  { set +x
  $as_echo "$at_srcdir/demo.at:535: case \$host in
 -hppa*|x86_64*|s390*)
-+hppa*|x86_64*|s390*|arm*|mips*)
++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
    # These hosts cannot use non-PIC shared libs
    exit 77 ;;
  *-solaris*|*-sunos*)
@@ -27,7 +27,7 @@  Skip the nopic test on ARM and MIPS systems.
  at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
  ( $at_check_trace; case $host in
 -hppa*|x86_64*|s390*)
-+hppa*|x86_64*|s390*|arm*|mips*)
++hppa*|x86_64*|s390*|arm*|mips*|riscv*)
    # These hosts cannot use non-PIC shared libs
    exit 77 ;;
  *-solaris*|*-sunos*)