diff mbox series

[bug#65758,v6,40/55] gnu: Add python-django-treebeard.

Message ID e8d5becc556741cdd8c49465b53dd23997e93b33.1693931491.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v6,01/55] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 4:31 p.m. UTC
* gnu/packages/django.scm (python-django-treebeard): New variable.
---
 gnu/packages/django.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7458f64ee4..6f772f3a5f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -421,6 +421,34 @@  (define-public python-django-taggit
 application for simple tagging.")
     (license license:bsd-3)))
 
+(define-public python-django-treebeard
+  (package
+    (name "python-django-treebeard")
+    (version "4.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "django-treebeard" version))
+       (sha256
+        (base32 "12s6xyiyjvxnjdbnbj9wab5mdj69d1aj77lkfzmj9mbp0823baw4"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-django
+                             python-sqlparse))
+    (native-inputs (list python-wheel
+                         python-pytest-django))
+    (home-page "https://github.com/django-treebeard/django-treebeard/")
+    (synopsis "Efficient tree implementations for Django")
+    (description
+     "This package provides @code{django-treebeard}, an efficient tree
+implementations for Django.  It includes 3 different tree implementations
+with the same API:
+@itemize
+@item Adjacency List
+@item Materialized Path
+@item Nested Sets
+@end itemize")
+    (license license:bsd-3)))
+
 (define-public python-easy-thumbnails
   (package
     (name "python-easy-thumbnails")