diff mbox series

[bug#65758,v6,39/55] gnu: Add python-django-modelcluster.

Message ID 6795871d2c4ec964b005175644243c2784d11a19.1693931491.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v6,01/55] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 4:31 p.m. UTC
* gnu/packages/django.scm (python-django-modelcluster): New variable.
---
 gnu/packages/django.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7c4a09680f..7458f64ee4 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -898,6 +898,40 @@  (define-public python-django-contrib-comments
 entries, photos, book chapters, or anything else.")
     (license license:bsd-3)))
 
+(define-public python-django-modelcluster
+  (package
+    (name "python-django-modelcluster")
+    (version "6.0")
+    ;; tests are not packaged in pypi
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wagtail/django-modelcluster")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19xskhh2wvl696jmji54b1p70kjbcxzwmw3v5ic54ifn8cx6za57"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "runtests.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs (list python-django python-pytz))
+    (native-inputs
+     (list python-django-taggit tzdata-for-tests))
+    (home-page "https://github.com/wagtail/django-modelcluster")
+    (synopsis
+     "Django extension to allow working with 'clusters' of models as a single unit")
+    (description
+     "This package provides a Django extension to allow working with
+'clusters' of models as a single unit, independently of the database")
+    (license license:bsd-3)))
+
 (define-public python-django-pipeline
   (package
     (name "python-django-pipeline")