diff mbox series

[bug#65758,v6,38/55] gnu: python-django-filter: Update to 22.1.

Message ID 11883927d2590ad1286a804623f3ffda55bb08f0.1693931491.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v6,01/55] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 4:31 p.m. UTC
* gnu/packages/django.scm (python-django-filter): Update to 22.1.
[build-sytem] Use pyproject-build-system.
[synopsis] Simpler synopsis.
[description] More precise description.
---
 gnu/packages/django.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 3a4a96c560..7c4a09680f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -571,14 +571,14 @@  (define-public python-django-haystack
 (define-public python-django-filter
   (package
     (name "python-django-filter")
-    (version "2.3.0")
+    (version "22.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "django-filter" version))
               (sha256
                (base32
-                "1bz5qzdk9pk4a2lp2yacrdnqmkv24vxnz4k3lykrnpc3b7bkvrhi"))))
-    (build-system python-build-system)
+                "19abb7ikcjxfwggjh0bx40sx2dpv7q60bchva6r86zjgx1v3nizd"))))
+    (build-system pyproject-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -590,12 +590,12 @@  (define-public python-django-filter
            python-django-crispy-forms python-mock
            tzdata-for-tests))
     (home-page "https://django-filter.readthedocs.io/en/latest/")
-    (synopsis "Reusable Django application to filter querysets dynamically")
+    (synopsis "Django application filtering querysets dynamically")
     (description
-     "Django-filter is a generic, reusable application to alleviate writing
-some of the more mundane bits of view code.  Specifically, it allows users to
-filter down a queryset based on a model’s fields, displaying the form to let
-them do this.")
+     "This package provides @code{django-filter}, a generic and
+reusable application to alleviate writing some of the more mundane bits of
+view code.  Specifically, it allows users to filter down a queryset based on a
+model’s fields, displaying the form to let them do this.")
     (license license:bsd-3)))
 
 (define-public python-django-allauth