diff mbox series

[bug#65758,v6,43/55] gnu: Add python-willow.

Message ID 5286ad8e4016f4d4f686811c9bf882cad2a3d8e3.1693931491.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v6,01/55] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 4:31 p.m. UTC
* gnu/packages/python-xyz.scm (python-willow): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b40f711d72..b107a7f4a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8833,6 +8833,33 @@  (define-public python-pixelmatch
 metrics.")
     (license license:isc)))
 
+(define-public python-willow
+  (package
+    (name "python-willow")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Willow" version))
+       (sha256
+        (base32 "12k5mv9jh0f5vjm87ss4d7kbkrcb3n5fa0gk9pvf9n3jk3d2rr1z"))))
+    (build-system pyproject-build-system)
+    (inputs
+     (list freetype lcms libjpeg-turbo libtiff libwebp openjpeg zlib))
+    (propagated-inputs
+     (list python-defusedxml python-filetype))
+    (home-page "https://github.com/wagtail/Willow")
+    (synopsis
+     "A wrapper that combines the functionality of multiple Python image
+libraries into one API")
+    (description
+     "Willow is a simple image library that combines the APIs of Pillow, Wand
+and OpenCV. It converts the image between the libraries when necessary. Willow
+currently has basic resize and crop operations, face and feature detection and
+animated GIF support. New operations and library integrations can also be
+easily implemented.")
+    (license license:bsd-3)))
+
 (define-public python-imagecodecs
   (package
     (name "python-imagecodecs")