diff mbox series

[bug#65758,v6,49/55] gnu: Add python-telepath.

Message ID 9bd37ac043c0340188c8f5e73f1a7a1c77ffd2ea.1693931491.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v6,01/55] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 5, 2023, 4:31 p.m. UTC
* gnu/packages/django.scm (python-telepath): New variable.
---
 gnu/packages/django.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index fb00bf5963..e0fec3caa9 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1633,3 +1633,32 @@  (define-public python-django-cleanup
 ImageField and their subclasses.  Files set as default values for any
 FileField are not deleted.")
     (license license:expat)))
+
+(define-public python-telepath
+  (package
+    (name "python-telepath")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "telepath" version))
+       (sha256
+        (base32 "0k7q5dqgvcwnslb82ah0g6p772jzjmb6fd4wcdc8r46ibsjg4k7g"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-django python-pytest-django))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (lambda _
+                   (setenv "DJANGO_SETTINGS_MODULE" "telepath.test_settings")
+                   (invoke "django-admin" "test" "--pythonpath=."))
+                 (format #t "test suite not run~%")))))))
+    (home-page "https://github.com/wagtail/telepath")
+    (synopsis "Exchanging data between Python and JavaScript")
+    (description
+     "This package provides @code{telepath}, a library for exchanging data
+between Python and JavaScript.")
+    (license license:bsd-3)))